Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6226 closed defect (duplicate)

NPE after trying to download a deleted way

Reported by: skyper Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: Exception deleted way Cc:

Description

I tried to download deleted way.

The correct error message appeared but after that I got an NPE.

Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-04-16 01:31:34
Last Changed Author: stoecker
Revision: 4030
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-04-16 00:32:30 +0200 (Sat, 16 Apr 2011)
Last Changed Rev: 4030

GET http://api.openstreetmap.org/api/capabilities... OK
Communications with http://api.openstreetmap.org/api established using protocol version 0.6.
loading plugin 'turnlanes' (version 25783)
loading plugin 'reverter' (version 25578)
loading plugin 'buildings_tools' (version 25469)
loading plugin 'waydownloader' (version 25190)
loading plugin 'multipoly-convert' (version 25192)
Silent shortcut conflict: 'tools:multipolyconv' moved by 'tools:mirror' to 'Alt+Umschalt+M'.
loading plugin 'utilsplugin2' (version 25817)
loading plugin 'terracer' (version 25199)
Silent shortcut conflict: 'tools:Terracer' moved by 'tool:revert' to 'Alt+Umschalt+T'.
RemoteControl::Accepting connections on port 8111
Silent shortcut conflict: 'subwindow:selection' moved by 'tools:Terracer' to 'Alt+C'.
Silent shortcut conflict: 'subwindow:conflict' moved by 'subwindow:selection' to 'Alt+Umschalt+C'.
Silent shortcut conflict: 'subwindow:mappaint' moved by 'tools:multipolyconv' to 'Alt+M'.
GET http://api.openstreetmap.org/api/0.6/way/54570668/full
GET http://api.openstreetmap.org/api/0.6/way/54570668/relations
java.lang.NullPointerException
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseDragged(SelectAction.java:166)
	at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:320)
	at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:319)
	at java.awt.Component.processMouseMotionEvent(Component.java:6156)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3285)
	at java.awt.Component.processEvent(Component.java:5877)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4469)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4142)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
	at java.awt.Container.dispatchEventImpl(Container.java:2149)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)


Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by skyper

Forgot:

There was not any layer when download was started and now there is an empty layer centered at 0°/0°.

comment:2 Changed 12 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:3 Changed 12 years ago by stoecker

Closed as duplicate of #6131.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.