Modify

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#6131 closed defect (fixed)

[patch] NPE in SelectAction while dragging

Reported by: Zverikk Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Build-Date: 2011-03-20 21:21:37
Revision: 3992
Is-Local-Build: true

Identification: JOSM/1.5 (3992 SVN ru)
Memory Usage: 39 MB / 63 MB (4 MB allocated, but free)
Java version: 1.6.0_15, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista
Dataset consistency test: No problems found

Plugin: PicLayer (25219)
Plugin: buildings_tools (25469)
Plugin: editgpx (25407)
Plugin: measurement (25199)
Plugin: openstreetbugs (25540)
Plugin: public_transport (25192)
Plugin: reverter (25429)

java.lang.NullPointerException
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseDragged(SelectAction.java:166)
	at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

select-drag-npe.patch (638 bytes) - added by Zverikk 12 years ago.
better fix (lastMousePos == null)

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Zverikk

Probably #5725 is the same bug.

Changed 12 years ago by Zverikk

Attachment: select-drag-npe.patch added

better fix (lastMousePos == null)

comment:2 Changed 11 years ago by stoecker

Ticket #6226 has been marked as a duplicate of this ticket.

comment:3 Changed 11 years ago by stoecker

Ticket #5916 has been marked as a duplicate of this ticket.

comment:4 Changed 11 years ago by stoecker

Ticket #5735 has been marked as a duplicate of this ticket.

comment:5 Changed 11 years ago by stoecker

Ticket #5866 has been marked as a duplicate of this ticket.

comment:6 Changed 11 years ago by stoecker

Ticket #6230 has been marked as a duplicate of this ticket.

comment:7 Changed 11 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4039/josm]:

fix #6131 - NPE with Drag&Drop - patch by Zverikk

comment:8 Changed 11 years ago by Don-vip

Ticket #5725 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.