Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6219 closed defect (fixed)

can create a way that references same node twice

Reported by: richlv Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

have some way, select two nodes that are one node apart, merge them. delete the node that previously was between those two.

a way, referencing same node twice, is born. validator warns about it, but it is very hard to get rid of this problem now.

verified in 4021

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4053/josm]:

fix #6219 - don't create ways containing a double node

comment:2 Changed 9 years ago by stoecker

Validator has a fix option to solve this, but it should not be produced at all.

comment:3 Changed 9 years ago by stoecker

Ticket #6234 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by stoecker

Ticket #6243 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by richlv

problem not reproducible in josm 4064

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.