Modify

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#6216 closed defect (wontfix)

unhandled exception on startup

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

JOSM is still loading and I get an unhandled exception on startup:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-03-31 01:31:31
Last Changed Author: bastiK
Revision: 4011
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-30 22:25:20 +0200 (Wed, 30 Mar 2011)
Last Changed Rev: 4011

Identification: JOSM/1.5 (4011 en)
Memory Usage: 30 MB / 1956 MB (16 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Plugin: ImportImagePlugin
Plugin: PicLayer
Plugin: alignways
Plugin: buildings_tools
Plugin: dataimport
Plugin: osmarender
Plugin: pdfimport
Plugin: photo_geotagging
Plugin: public_transport
Plugin: restart
Plugin: reverter
Plugin: tagging-preset-tester
Plugin: undelete
Plugin: waypoint_search

java.lang.ArrayIndexOutOfBoundsException: 1

at org.openstreetmap.josm.io.MirroredInputStream.checkLocal(MirroredInputStream.java:187)
at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:70)
at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:31)
at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.fromSourceEntry(MapPaintStyles.java:158)
at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:143)
at org.openstreetmap.josm.gui.preferences.MapPaintPreference.initialize(MapPaintPreference.java:160)
at org.openstreetmap.josm.Main.<init>(Main.java:237)
at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:58)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:221)

Attachments (0)

Change History (12)

comment:1 Changed 10 years ago by dieterdreist

Priority: blockernormal

Second time it worked ;-)
Might still be interesting for investigation...

comment:2 Changed 10 years ago by stoecker

Resolution: wontfix
Status: newclosed

Happens when you use 4022 once and then later use a pre 4022 version (like your 4011). This is due to updating of preferences structure and missing error checks in older version.

comment:3 Changed 10 years ago by stoecker

Ticket #6242 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by stoecker

Ticket #6346 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by stoecker

Ticket #6299 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by stoecker

Ticket #6352 has been marked as a duplicate of this ticket.

comment:7 Changed 10 years ago by stoecker

Ticket #6383 has been marked as a duplicate of this ticket.

comment:8 Changed 10 years ago by anonymous

Ticket #6389 has been marked as a duplicate of this ticket.

comment:9 Changed 10 years ago by skyper

Ticket #6439 has been marked as a duplicate of this ticket.

comment:10 Changed 10 years ago by stoecker

Ticket #6451 has been marked as a duplicate of this ticket.

comment:11 Changed 10 years ago by stoecker

Ticket #6508 has been marked as a duplicate of this ticket.

comment:12 Changed 9 years ago by simon04

Ticket #7860 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.