Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6188 closed defect (duplicate)

Contourmerge crashed during purge of 9k nodes and their dependent relations

Reported by: Polyglot Owned by: team
Priority: normal Milestone:
Component: Plugin contourmerge Version: latest
Keywords: Cc:

Description

I had used contourmerge during me editing session, but I wasn't using it at the moment of the crash.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-04-03 01:31:55
Last Changed Author: stoecker
Revision: 4012
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-04-02 11:37:30 +0200 (Sat, 02 Apr 2011)
Last Changed Rev: 4012

Identification: JOSM/1.5 (4012 nl)
Memory Usage: 247 MB / 247 MB (8 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: AddrInterpolation (25199)
Plugin: DirectUpload (25199)
Plugin: FixAddresses (25374)
Plugin: OpeningHoursEditor (25190)
Plugin: alignways (25199)
Plugin: buildings_tools (25469)
Plugin: contourmerge (25626)
Plugin: download_along (25190)
Plugin: editgpx (25407)
Plugin: ext_tools (25338)
Plugin: mapdust (25754)
Plugin: measurement (25199)
Plugin: public_transport (25192)
Plugin: reverter (25578)
Plugin: scripting (25200)
Plugin: terracer (25199)
Plugin: turnrestrictions (25465)
Plugin: utilsplugin2 (25190)
Plugin: waydownloader (25190)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=1118498863 version=1 V lat=50.873012,lon=4.7099552}

at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:343)
at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1287)
at org.openstreetmap.josm.plugins.contourmerge.ContourMergeModel.ensureSelectedNodesConsistent(ContourMergeModel.java:478)
at org.openstreetmap.josm.plugins.contourmerge.ContourMergeModel.dataChanged(ContourMergeModel.java:502)
at org.openstreetmap.josm.data.osm.event.DataChangedEvent.fire(DataChangedEvent.java:26)
at org.openstreetmap.josm.data.osm.DataSet.fireEventToListeners(DataSet.java:908)
at org.openstreetmap.josm.data.osm.DataSet.endUpdate(DataSet.java:890)
at org.openstreetmap.josm.command.PurgeCommand.executeCommand(PurgeCommand.java:119)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:36)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:58)
at org.openstreetmap.josm.actions.PurgeAction.actionPerformed(PurgeAction.java:206)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by skyper

Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by skyper

Closed as duplicate of #6163.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.