Modify

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#6161 closed defect (fixed)

Validating a file

Reported by: geotandem Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Lunch the validator

What is the expected result?
The list of errors and warning

What happens instead?
Une erreur inattendue est survenue (unexpected error)
Il s'agit d'une erreur de codage (It's a coing error)
Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-03-09 12:21:24
Last Changed Author: Upliner
Revision: 3966
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-09 11:48:50 +0100 (Wed, 09 Mar 2011)
Last Changed Rev: 3966

Identification: JOSM/1.5 (3966 fr)
Memory Usage: 85 MB / 455 MB (29 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=23331686 version=55 MVT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=106342248 version=1 VT nodes=[{Node id=253104019 version=10 V lat=45.7838766,lon=-73.4864457}]} has only one node
[WARN - ZERO NODES] Way {Way id=24816876 version=22 MVT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=3866653 version=13 MVT nodes=[]} has zero nodes


Plugin: openstreetbugs (25664)
Plugin: turnrestrictions (25465)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.Coastlines.endTest(Coastlines.java:69)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:170)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(

Attachments (1)

031H14.0.0.1.Ed.osm (1011.3 KB) - added by geotandem 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by geotandem

Attachment: 031H14.0.0.1.Ed.osm added

comment:1 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

In [4073/josm]:

Fix #6161 Validating a file

comment:2 Changed 9 years ago by anonymous

Ticket #6413 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.