Modify

Opened 9 years ago

Closed 9 years ago

#6113 closed defect (fixed)

removing "mandatory" arrows on some types of ways

Reported by: richlv Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

after upgrading to 3966 from 3751, some types of ways seem to always have arrows - and not at node locations, but across way segments as well, depending on segment length and zoom.

this so far has been observed on rivers and tram lines.

such a change is quite a regression for my workflow, because i rely on arrows to quickly identify node locations, segment lengths and so on. these arrows clutter the view a lot.

note that arrows on all ways on all nodes without these new "segment" arrows is the desired end result - either by default or by providing a configuration option. i looked in normal & advanced preferences (searching for "arrow" and "draw"), but couldn't find anything relevant

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by richlv

this looks like possibly a combination of 2 issues.

  1. arrows are not drawn on nodes as before but dynamically along way segments;
  2. even though "only interesting direction hints" option is disabled, arrows only appear on oneways, rivers and such objects

comment:2 Changed 9 years ago by mjulius

Resolution: fixed
Status: newclosed

In [3994/josm]:

fix #6113 - removing "mandatory" arrows on some types of ways
Since oneway arrows are now different from way direction arrows they need to be treated separately.
They now can be turned on and off independently.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.