Modify

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6087 closed defect (fixed)

Top level "fix warnings" in Validator can delete good information

Reported by: dan@… Owned by: team
Priority: blocker Milestone:
Component: Core validator Version: latest
Keywords: validator unnamed ways Cc:

Description

If a validator run results in some warnings which are automatically fixable, fixing all warnings at the top level will also "fix" unnamed highways by removing them altogether. But they shouldn't/can't be fixed this way. Clicking on that specific warning category greys out the "fix" button, as it should - it's just when all warnings are fixed at the top level (by clicking on the "Warnings" header first) that they are removed.

How to recreate (JOSM Version 3966):

Create a way with the tag of highway=residential, but don't give it a name. Then create a node in a different place with no tags, and then copy and paste it into the same position (zoom in to the limits of what JOSM allows to ensure it is pasted exactly in the same spot). When validator is run, it will give a few warnings, including "unnamed ways" which is not automatically fixable individually, and duplicate nodes and/or unconnected node warnings (depending on version of JOSM) which is fixable. If the fixable categories are clicked on and the "Fix" button selected, it works fine. But if the top-level "Warnings" is clicked on, and the "Fix" button clicked (which should fix all the fixable warnings but leave everything else alone), it not only fixes the duplicate nodes, but also "fixes" the newly created highway by removing it, which it shouldn't.

I consider this a significant priority since people who haven't noticed this behaviour (which category I have to place myself in until I discovered this) can easily accidentally delete unnamed, but otherwise completely valid ways by asking JOSM to "fix" issues that it can, without even realizing they've done so. A particularly nasty problem if you've downloaded a region to work on that others have spent time tracing out, but not naming, roads.

Attachments (1)

validatorfail.osm (602 bytes) - added by Adam Dunn 9 years ago.
Minimal osm file to cause bug

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by skyper

Component: CoreCore validator
Priority: majorcritical

I think this is critical if not even a blocker

Changed 9 years ago by Adam Dunn

Attachment: validatorfail.osm added

Minimal osm file to cause bug

comment:2 Changed 9 years ago by Adam Dunn

My method to reproduce (last tested in JOSM 3966):

  1. Download attached validatorfail.osm file (this is a minimal file to reproduce the bug, and is easily human readable in any text editor)
  2. Run Validator
  3. Click on "Warnings" category, then click "Fix" button
  4. Watch road disappear

comment:2 Changed 9 years ago by Adam Dunn

My method to reproduce (last tested in JOSM 3966):

  1. Download attached validatorfail.osm file (this is a minimal file to reproduce the bug, and is easily human readable in any text editor)
  2. Run Validator
  3. Click on "Warnings" category, then click "Fix" button
  4. Watch road disappear

comment:3 Changed 9 years ago by skyper

Priority: criticalblocker

This also happens with latest.

The option is not even correct, because you can not solve all warning. It should only be offered if you can fix all but not only a few of the subcategories.

As it can delete lot of work unnoticed by the user it is a blocker for me.

comment:4 Changed 8 years ago by skyper

Please, this is very dangerous, just do offer to fix on the top levels

Thanks

r4127

comment:5 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4131/josm]:

fix #6087 - don't fix validation stuff, which is not fixable

comment:6 in reply to:  5 Changed 8 years ago by skyper

Replying to stoecker:

In [4131/josm]:

fix #6087 - don't fix validation stuff, which is not fixable

Thanks a lot.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.