Modify

Opened 11 years ago

Closed 11 years ago

#6086 closed defect (fixed)

Validator doesn't like Christian churches

Reported by: dan@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: validator error Cc:

Description

How to recreate (JOSM Version 3966):

Create a node, and set amenity=place_of_worship, religion=christian. Run Validator, which will report an error of "Illegal tag/value combination". Setting religion to other faiths keeps the validator happy.

Attachments (0)

Change History (10)

comment:1 Changed 11 years ago by Zverikk

Because religion=christian needs denomination=*. Without denomination it is indeed incorrect.

comment:2 Changed 11 years ago by skyper

no it is not incorrect and perfectly valid. That the denomination is missing does not mean that this is not a christian church. I would say that validator should give you a better description of the problem and do not group it under "Illegal tag/value combination".

Last edited 11 years ago by skyper (previous) (diff)

comment:3 Changed 11 years ago by Zverikk

I agree that it's not an error, but should be a warning, but religion=christian has no use without denomination and is incomplete. Like place=* without name.

comment:4 Changed 11 years ago by dan@…

At the least, I would also concede that it might generate a warning, but not an error. I see no indication or justification that a denomination should be required. In particular, the OpenStreetMap wiki doesn't mention this "requirement" at http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dplace_of_worship, and in fact uses amenity=place_of_worship and religion=christian as its example, without mention of denomination. Of course, it does provide useful additional information if known, and helps to fully describe the amenity, but knowing that a place of worship is Christian rather than Buddhist does provide useful information to people, even if the denomination remains unknown until someone learns what it is and adds it. Just as adding a "service_times" tag may be useful if known, but hardly an error if missing.

comment:5 Changed 11 years ago by Zverikk

When we were travelling across Latvia, we noticed that almost every town had three christian churches: orthodox, catholic and lutheran. And none for other religions. That's the example when denomination should be required :) But in some cases it isn't, of course. Warning should be ok.

comment:6 Changed 11 years ago by Sam

I've found it only likes some denominations. I accepts Catholic Churches but not Ukrainian Orthodox.

comment:7 Changed 11 years ago by skyper

Component: CoreCore validator

comment:8 Changed 11 years ago by rickmastfan67

Ticket #6114 has been marked as a duplicate of this ticket.

comment:9 Changed 11 years ago by ceyockey

In my opinion, 'religion=Christian' is a valid and useful tag assignment. We want to ensure that people can provide information which is valid but not necessarily complete. There are many small Christian denominations in the United States (my home) and I can generally say that a particular church is Christian, but not necessarily without additional investigation, which might rely upon information we cannot include in the map due to licensing constraints (i.e. church website). Thus, designating a church as Christian and providing a link to the church's website is as far as we can go without violating licensure requirements . . . in some cases. This relates to casual observation of a venue, which is the most that many mappers would be in a position to do. In other words, supporting 'religion=Christian' supports the notion of editors providing valid information without being forced to provide complete information.

comment:10 Changed 11 years ago by malenki

Resolution: fixed
Status: newclosed

Behaviour has been changed back to "normal"; christian without denomination not longer is marked as error.
Change happened between 4022 and 4036

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.