Modify

Opened 9 years ago

Closed 9 years ago

#6007 closed defect (fixed)

rev 3922 (local build) runs out of memory when trying to upload to osm

Reported by: hjart Owned by: hjart
Priority: critical Milestone:
Component: Core Version: latest
Keywords: out of memory Cc:

Description

On my system 3922 behaves fine until I hit 'Upload to OSM' after which time cpu and memory use shoots up wildly and after a short while gives me the attached msg. No attempt to upload succeeds.

The text below is from the console:

java.lang.OutOfMemoryError: GC overhead limit exceeded

at java.util.ArrayList.<init>(ArrayList.java:112)
at java.util.ArrayList.<init>(ArrayList.java:119)
at org.openstreetmap.josm.data.validation.tests.CrossingWays.getSegments(CrossingWays.java:148)
at org.openstreetmap.josm.data.validation.tests.CrossingWays.visit(CrossingWays.java:87)
at org.openstreetmap.josm.data.osm.Way.visit(Way.java:135)
at org.openstreetmap.josm.data.validation.Test.visit(Test.java:139)
at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:58)
at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:139)
at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:162)
at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:195)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
at java.awt.Component.processMouseEvent(Component.java:6267)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6032)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)

21-02-2011 17:22:49 sun.awt.X11.XToolkit processException
WARNING: Exception on Toolkit thread

Attachments (1)

Josm-OutOfMemory.png (24.8 KB) - added by hjart 9 years ago.
Out of memory

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by hjart

Attachment: Josm-OutOfMemory.png added

Out of memory

comment:1 Changed 9 years ago by stoecker

Owner: changed from team to hjart
Status: newneedinfo

How much memory do you give Java? The Java defaults are much too small.

comment:2 Changed 9 years ago by Zverikk

Not too small, I start josm with "java -jar josm-latest.jar" all the time, and only experience OOM error after very intensive use of Bing imagery (#5971).

comment:3 Changed 9 years ago by bastiK

confirmed, this is probably related to [3922]

comment:4 Changed 9 years ago by hjart

I tried giving it 2500M (out of my 4000), but to no avail. JOSM ate all of it and made the whole system unresponsive. Had to kill it. And I never had to give Java extra memory before (and I've actually used JOSM quite a lot over the last year ... and I have to thank you for all the work you've put in it).

comment:5 Changed 9 years ago by *Martin*

Affects me too even with -Xmx1240m. It is probably caused by validator. In r3915 it worked.

comment:6 Changed 9 years ago by bastiK

Resolution: fixed
Status: needinfoclosed

In [3923/josm]:

fixed #6007 - runs out of memory on validater cross ways check (TODO: initializeGridDetail hack needs proper implementation)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain hjart.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.