Modify

Opened 9 years ago

Closed 7 years ago

#5971 closed defect (duplicate)

WMS-Plugin memory-leak

Reported by: Bürste Owned by: Bürste
Priority: normal Milestone:
Component: Core Version: tested
Keywords: imagery wms bing memoryleak Cc: Upliner

Description (last modified by stoecker)

When using WMS Plugin I ran every time out of memory.

Memory usage as Private Bytes according Process Explorer.

Reproduce:

-Open JOSM via Webstart. Memory usage: 115M
-Load OSM Data, best for testing is a hugh dataset. 180M
-Open Bing Layer 187M
-Zoom in 188M
-Scroll 1 Minute 326M
-Scroll another Minute 336M
-Close Layer, Open next Bing Layer 337M
-Scroll 1 Minute (with degraded performance) 360M
-Close Layer, Open next Bing Layer 361M
-Load some additionally OSM Data and now JOSM is nearly completly unusable 361M

If you now would use it further its only a question of time when it would run completly out of memory.

Attachments (0)

Change History (8)

comment:1 Changed 9 years ago by Upliner

Cc: Upliner added

comment:2 Changed 9 years ago by Zverikk

I second this, recently there've been a lot of OutOfMemoryErrors after using Bing layer. I'm experiencing one right now, spiced up by "Autosafe failed" messages in the console.

comment:3 Changed 9 years ago by Bürste

Component: Core imageryCore
Description: modified (diff)
Keywords: imagery wms bing memoryleak added
Priority: majornormal

comment:4 Changed 9 years ago by Bürste

Description: modified (diff)

comment:5 Changed 7 years ago by skyper

What is the status of this ticket ?

comment:6 Changed 7 years ago by stoecker

Description: modified (diff)
Owner: changed from team to Bürste
Status: newneedinfo

comment:7 Changed 7 years ago by skyper

See also #7980

comment:8 Changed 7 years ago by stoecker

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #7980.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Bürste.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.