Modify

Opened 9 years ago

Closed 9 years ago

#5990 closed defect (fixed)

NPE when clicking anywhere in the viewport in rev 3915 (local build)

Reported by: hjart Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Build-Date: 2011-02-20 06:34:45
Revision: 3915
Is-Local-Build: true

Identification: JOSM/1.5 (3915 SVN da)
Memory Usage: 319 MB / 672 MB (134 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectUpload (25199)
Plugin: buildings_tools (25192)
Plugin: editgpx (25192)
Plugin: graphview (25199)
Plugin: mapdust (25312)
Plugin: osmarender (25192)
Plugin: reverter (25190)
Plugin: routing (25199)
Plugin: undelete (25199)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.TMSLayer$10$1.mouseClicked(TMSLayer.java:447)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:253)
	at java.awt.Component.processMouseEvent(Component.java:6270)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6032)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4247)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by hjart

This problem still exists in rev 3919. It occurs when a wms layer is enabled and persists after said layer is deleted.

comment:2 Changed 9 years ago by stoecker

Ticket #6003 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

In [3921/josm]:

fix #5990 - NPE

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.