Modify

Opened 9 years ago

Closed 8 years ago

Last modified 3 years ago

#5983 closed defect (fixed)

do not render incline like oneway

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version: latest
Keywords: oneway incline Cc:

Description (last modified by simon04)

It is missleading if incline is rendered the same way oneway is rendered.

What do you render if a street goes downhill as oneway street ?

r3902

Attachments (1)

incline_revert.osm (55.8 KB) - added by skyper 9 years ago.
osm

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by skyper

Priority: normalmajor

by the way incline=-1 or (-8) are rendered wrong and direction=up/down is not rendered at all

Last edited 9 years ago by skyper (previous) (diff)

comment:2 Changed 9 years ago by skyper

Priority: majorblocker

This is a big bug and the methode is broken for incline anyway. Please stop rendering incline !!!!

Have a look at the attached file if you do not belief. The only two oneway ways are on the left side. I had to revert all ways with negative incline-values to show to be rendered.

r3973

Changed 9 years ago by skyper

Attachment: incline_revert.osm added

osm

comment:3 Changed 8 years ago by skyper

I wounder how blockers are treated. Shouldn't these tickets be fixed before releasing a new tested version ?

comment:4 Changed 8 years ago by stoecker

Priority: blockernormal

comment:5 in reply to:  4 ; Changed 8 years ago by skyper

Replying to stoecker:

Hey, Dirk.

I will not change priority but I think this is at least a major bug.

  1. it is not possible to render incline and oneway within one thread.
  2. The methode for incline is broken anyway.

Please, just stop rendering incline and we can change this ticket into a normal enhancement.

Thanks a lot.

comment:6 Changed 8 years ago by stoecker

This behaviour is there probably for 4 years, so it can't be a major bug. If I remember correctly it even was a request. So here different views exist. Maybe we need to change it, but it is in no way a major issue.

comment:7 Changed 8 years ago by NE2

Agree with this being a problem. A different arrow style should be used.

comment:8 Changed 8 years ago by skyper

The way I know it from paper maps, incline is often displayed with a large thin head of an error > with up to three in a row to show the degree of incline.

But I think that incline is quite difficult because it changes quite often and with detailed data you have to group and calculate some average to render well, otherwise you will end up to have it only rendered in high zoom levels. (Have a look at my example.)

In a matter of facts the grouping will be needed for oneway, too.

comment:9 Changed 8 years ago by simon04

Description: modified (diff)

#7588 is related. The other "direction keys" (oneway? | aerialway=* | waterway=stream | waterway=river | waterway=canal | waterway=drain | waterway=rapids | "piste:type"=downhill | "piste:type"=sled | man_made="piste:halfpipe" | junction=roundabout) are directly related to the "flow" of/on this object, but incline is not. Therefore, I also favour to remove incline from the "direction keys".

For those (few) who are interested in mapping inclines, a custom style is probably more useful.

Replying to stoecker:

If I remember correctly it even was a request. So here different views exist.

I couldn't find a corresponding ticket on Trac …

Last edited 8 years ago by simon04 (previous) (diff)

comment:10 Changed 8 years ago by simon04

To (probably) resolve this issue: Are there objections to remove incline from the "direction keys"? :-)

comment:11 in reply to:  10 ; Changed 8 years ago by stoecker

I couldn't find a corresponding ticket on Trac …

You also need to check josm-dev, talk.de lists, the web forum and my personal e-mail folder :-)

To (probably) resolve this issue: Are there objections to remove incline from the "direction keys"? :-)

Not from my side.

comment:12 in reply to:  11 Changed 8 years ago by simon04

Replying to stoecker:

I couldn't find a corresponding ticket on Trac …

You also need to check josm-dev, talk.de lists, the web forum and my personal e-mail folder :-)

I won't :-). As written above, in my opinion, incline should not be mixed with the other direction keys.

If someone needs incline to be rendered as oneway, the preference keys tags.direction, tags.reversed_direction can be edited. Maybe, a custom style (say, positive incline: red, negative incline: green) is better suited for extensively mapping inclines.

comment:13 in reply to:  5 Changed 8 years ago by skyper

Replying to skyper:

Please, just stop rendering incline and we can change this ticket into a normal enhancement.

My opinion did not change over the last year.

comment:14 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In 5188/josm:

fix #5983 - do not render incline like oneway

comment:15 Changed 8 years ago by simon04

Ticket #7588 has been marked as a duplicate of this ticket.

comment:16 Changed 3 years ago by Klumbumbus

There are now atleast two style, which render incline:

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.