Modify

Opened 13 years ago

Closed 7 weeks ago

#59 closed enhancement (fixed)

[patch] Dialog menu

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: sidebar menu Cc:

Description (last modified by stoecker)

Move toggle buttons for layer, object property, etc. dialogs to a new top level menu called "Dialogs" (same as in Gimp). They are not used very often and we can use the space for other things.

Attachments (2)

wip1.patch (48.2 KB) - added by xeen 8 years ago.
wip1.png (40.7 KB) - added by xeen 8 years ago.

Download all attachments as: .zip

Change History (26)

comment:1 Changed 12 years ago by ramack

Priority: majorminor

I don't know how useful this actually is - what do you need the space for? But just for the fun of it here is a hacked version of josm: http://n.ethz.ch/~rmack/josm/ticket59.jar and a patch
http://n.ethz.ch/~rmack/josm/ticket59_dialogs_menu.patch for all of those who want to see how it could look.

comment:2 Changed 11 years ago by stoecker

comment:3 Changed 11 years ago by stoecker

Owner: changed from imi to framm

comment:4 Changed 10 years ago by stoecker

Ticket #4390 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by stoecker

Ticket #5875 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by bastiK

Owner: changed from framm to team

comment:5 Changed 9 years ago by vsandre

Are there any plans to introduce this?

comment:6 Changed 9 years ago by bastiK

i'd say we aren't opposed to the idea

comment:7 in reply to:  6 ; Changed 9 years ago by skyper

Replying to bastiK:

i'd say we aren't opposed to the idea

I think it would be nice to be able to configure the left panel, or maybe even a window/box somewhere.

  • I do not know all shortcuts but some
  • I do not use all toggle buttons because I do not need some action and I do never close some.

Few toggle buttons I use quite often, but maybe I would just learn the shortcuts, if the buttons would disapear.

comment:8 in reply to:  7 Changed 9 years ago by anonymous

Keywords: sidebar menu added

Replying to skyper:

I think it would be nice to be able to configure the left panel, or maybe even a window/box somewhere.

This is one of the advantages of a separate menu. Because you still able to reach all sidebar elements but with an additional click. Elements of high priority could be send to the tool bar and will be reached within on click, too.

http://josm.openstreetmap.de/raw-attachment/ticket/5875/josm-sidebar.jpg

comment:9 Changed 9 years ago by bastiK

Nice "screenshot". Also, the lower left corner isn't exactly the best place for buttons that toggle dialogs to the right. Removing these toggle buttons completely would maybe be a too radical step, but this panel could be moved somewhere else, so the distinction between mapmode (select, add, zoom, ...) and dialog toggle is more clear to a new user. (The thin line, that separates the 2 types of buttons is sometimes not noticed.) Any suggestions how this could look like?

comment:10 in reply to:  9 Changed 9 years ago by vsandre

Replying to bastiK:

Any suggestions how this could look like?

This Windows menu is very common in other software products (especially painting programs).

If you want to see some buttons add them to the tool bar.
If you want this buttons on the right of the toolbar add a variable space element (see firefox).

Changed 8 years ago by xeen

Attachment: wip1.patch added

Changed 8 years ago by xeen

Attachment: wip1.png added

comment:11 Changed 8 years ago by vsandre

Replying to xeen

Nice Patch!!! Please remove the toggle buttons from the left, too.

comment:12 Changed 8 years ago by stoecker

Two suggestions:

  • Allow to configure the display of buttons in left menu (defaults to true)
  • When I do a right click into the title line of a ToggleDialog it would be nice when a popup with the toggle dialog selection appears. This would reduce (for advanced users only) the distance between dialog and dialog enable/disable.

If you want this buttons on the right of the toolbar add a variable space element (see firefox).

We have no variable spacer for now and I don't find it in your patch.

Could you modify the patch in a way, that the permanent MapFrame initialisation is not required (i.e. by turning of ToolBar support for now). I think this should be done step-by-step and not too many changes at once. Or do you already have a solution which does not required the MapView init?

comment:13 in reply to:  12 ; Changed 8 years ago by xeen

  • Allow to configure the display of buttons in left menu (defaults to true)

good idea

  • When I do a right click into the title line of a ToggleDialog it would be nice when a popup with the toggle dialog selection appears. This would reduce (for advanced users only) the distance between dialog and dialog enable/disable.

I don’t get it. Do you mean the window manager dependend context menu with e.g. move, close, maximize, minimize?

We have no variable spacer for now and I don't find it in your patch.

Yep, didn't include it, although I believe it’s useful outside of the scope of this bug, too. It can be implemented independently of this, though.

I think this should be done step-by-step and not too many changes at once.
Or do you already have a solution which does not required the MapView init?

I have been busy lately, so I could not work on it as much as I’d like. Also, since I still believe initializing the MapView right away makes many things simpler and there were no concrete concerns apart from that stuff might break I decided I won’t work around the issue. My current plan is to move MapView initialization, fix all issues I find and update the plugins if necessary. I’ll add the menu/toolbarbuttons when the former is commited to the main branch and has stabilized.

comment:14 in reply to:  13 ; Changed 8 years ago by stoecker

Replying to xeen:

  • When I do a right click into the title line of a ToggleDialog it would be nice when a popup with the toggle dialog selection appears. This would reduce (for advanced users only) the distance between dialog and dialog enable/disable.

I don’t get it. Do you mean the window manager dependend context menu with e.g. move, close, maximize, minimize?

No. The title lines of the toggle dialogs in right hand menu. A right-click-popup could show a menu, which contains all toggle-dialogs.

I think this should be done step-by-step and not too many changes at once.
Or do you already have a solution which does not required the MapView init?

I have been busy lately, so I could not work on it as much as I’d like. Also, since I still believe initializing the MapView right away makes many things simpler and there were no concrete concerns apart from that stuff might break I decided I won’t work around the issue. My current plan is to move MapView initialization, fix all issues I find and update the plugins if necessary. I’ll add the menu/toolbarbuttons when the former is commited to the main branch and has stabilized.

Is still don't see a reason for such a radical change. It should be possible to have a JosmAction, which is disabled when no MapFrame is active (like many other actions are, e.g. like UploadAction).

comment:15 in reply to:  14 Changed 8 years ago by xeen

It should be possible to have a JosmAction, which is disabled when no MapFrame is active (like many other actions are, e.g. like UploadAction).

It’s about (un)registering those actions. Without map frame JOSM doesn’t even know they exist. So in order to not move the map frame init the following needs to be done:

  • move toggle dialog creation somewhere earlier
  • update toggle dialogs so they don’t assume the map frame/map view is there on creation
  • implement map frame destroyed/created listener for all toggle dialogs

Especially the last point is a deal breaker for me, since it complicates the code for no good reason. Looking at what the map frame class does, it’s pretty much: toggle dialogs + map view + left hand toolbar + some utility features. If the dialogs are moved “up” not much remains and the left hand toolbar should probably be handled the same way as the top toolbar to make moving items between them saner to implement.

Long story short, why not ditch MapFrame altogether?

comment:16 Changed 8 years ago by simon04

I am looking forward to seeing the Windows menu to go live :). Unfortunately, there hasn't been an update for 2 weeks.

Is there a way to help the development? Is there a consensus concerning MapFrame?

comment:17 Changed 8 years ago by stoecker

Description: modified (diff)
Summary: Dialog menu[patch needs rework] Dialog menu

Can't we implement this step-by-step leaving the critical parts to the end? I hate to waste already spend efforts.

comment:18 Changed 8 years ago by stoecker

In [4590/josm]:

see #59 - patch by xeen - apply parts of the new Windows menu stuff

comment:19 Changed 8 years ago by akks

By the way, doesn`t we need another menu for all available MapModes?

comment:20 Changed 8 years ago by stoecker

Summary: [patch needs rework] Dialog menu(patch needs rework) Dialog menu

comment:21 Changed 2 years ago by Zverikk

Isn't this already resolved with the "Window" menu?

comment:22 Changed 7 weeks ago by Don-vip

Priority: minornormal
Resolution: fixed
Status: newclosed
Summary: (patch needs rework) Dialog menu[patch] Dialog menu

Yep, the current windows menu is ok for me.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.