Modify

Opened 11 years ago

Closed 10 years ago

#587 closed enhancement (fixed)

move ways between layers

Reported by: rvollmert@… Owned by: rvollmert@…
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc: none, landwirt@…

Description

Sometimes, I want to convert a gpx track or OSM gps points directly into a way (simplifying if appropriate). My current procedure is:

  1. load GPX file
  2. convert to data layer
  3. split way to cut out the part I want to include in OSM
  4. select and copy this way
  5. select OSM data layer
  6. paste
  7. adjust layers to make sure I see the GPX-data layer and the OSM layer, and move the pasted way back to lie exactly above the original.

This could be improved by either making paste not move the way, or by adding a "move/copy selection to other layer" command. I don't really have a preference.

Attachments (0)

Change History (7)

comment:1 Changed 11 years ago by anonymous

Type: defectenhancement

should have been an enhancment request

comment:2 Changed 10 years ago by stoecker

Component: Core validatorCore
Keywords: sfvscmksid removed
Priority: criticalmajor
Summary: lioresalmove ways between layers
Type: defectenhancement
Version: latest

comment:3 Changed 10 years ago by anonymous

Ticket #2003 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by Landwirt

Cc: landwirt@… added

I miss a "Move selection to new layer" feature.

comment:5 Changed 10 years ago by Gubaer

Owner: set to rvollmert@…
Status: newneedinfo

In r1890 there is a "Merge selection to other layer".

  1. load GPX file
  2. convert to data layer "GPX Data"
  3. create new data layer "Data New"
  4. split way to cut out the part I want to include in OSM
  5. select way
  6. invoke action "Merge selection" and choose "Data New" as target layer

Does this help?

comment:6 Changed 10 years ago by Landwirt

Although I would only be interested in steps 5 and 6, I would say yes.

comment:7 Changed 10 years ago by Gubaer

Resolution: fixed
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain rvollmert@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.