Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#586 closed enhancement (duplicate)

Easier method to create parallel ways

Reported by: rvollmert@… Owned by: framm
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

I would like to be able to shift each node of a way a given distance into the direction that is vertical to the tangent to the way at that node. This should make it a lot easier to create parallel ways.

  • I'm not sure what the UI should be like. It would be useful to shift a way by a specified distance (say 10m if you know that's how far the two ways of a motorway are separated), but also to have an interactive version, say a slider.
  • To actually use this to create parallel ways, duplication should either be integrated, or (my preference) the present duplication should be modified to duplicate in place.
  • For middle nodes, the normal direction could be computed as bisecting the angle of the two segments; the end nodes could be displaced at a right angle to the end segments.
  • I have no idea how this would interact with projections. I think it would suffice to do these operations in screen coordinates. That might not work with specifying an exact distance to shift, though.

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by anonymous

Summary: shift way normallyEasier method to create parallel ways

comment:2 Changed 11 years ago by anonymous

Resolution: duplicate
Status: newclosed

Duplicate of #67.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.