Modify

Opened 8 years ago

Closed 6 years ago

#5839 closed defect (fixed)

the Plugin "tagging-preset-tester" produce an error message

Reported by: tijuca Owned by: team
Priority: normal Milestone:
Component: Plugin tagging-preset-tester Version: latest
Keywords: Cc: FrViPofm

Description (last modified by skyper)

To prevent any side effects by other plugins I create a new local enviroment by deleting the folder ~/.josm in my $HOME so I get a clean new standard setting from JOSM.

I just installed the plugins restart and the tagging-preset-tester.

I load a own created preset, based on the preset from http://www.asamnet.de/~fischept/osm/oepnv_preset.xml.

Now I download a small part of OSM data. After this i press the buttons "Alt+Shift+A". Shortly appears the error message.
I tried also the Shortcut without an OSM data or *.osm local loaded, the error is the same.

error message of the plugin tagging-preset-tester

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-01-11 02:31:08
Last Changed Author: framm
Revision: 3784
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-01-11 00:30:13 +0100 (Tue, 11 Jan 2011)
Last Changed Rev: 3784

Identification: JOSM/1.5 (3784 de)
Memory Usage: 173 MB / 784 MB (41 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: restart (24396)
Plugin: tagging-preset-tester (22454)

java.lang.NullPointerException: Fehler: Das Bild 'empty.png' konnte nicht geladen werden. Das ist ein schwerwiegendes Konfigurationsproblem.
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:75)
	at org.openstreetmap.josm.plugins.taggingpresettester.TaggingCellRenderer.getListCellRendererComponent(TaggingCellRenderer.java:38)
	at javax.swing.plaf.basic.BasicComboBoxUI.getDisplaySize(BasicComboBoxUI.java:1345)
	at javax.swing.plaf.metal.MetalComboBoxUI.getMinimumSize(MetalComboBoxUI.java:333)
	at javax.swing.plaf.basic.BasicComboBoxUI.getPreferredSize(BasicComboBoxUI.java:908)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
	at java.awt.BorderLayout.layoutContainer(BorderLayout.java:815)
	at java.awt.Container.layout(Container.java:1481)
	at java.awt.Container.doLayout(Container.java:1470)
	at java.awt.Container.validateTree(Container.java:1568)
	at java.awt.Container.validateTree(Container.java:1575)
	at java.awt.Container.validateTree(Container.java:1575)
	at java.awt.Container.validateTree(Container.java:1575)
	at java.awt.Container.validate(Container.java:1540)
	at java.awt.Window.show(Window.java:861)
	at java.awt.Component.show(Component.java:1464)
	at java.awt.Component.setVisible(Component.java:1416)
	at java.awt.Window.setVisible(Window.java:842)
	at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(TaggingPresetTester.java:86)
	at org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTesterAction.actionPerformed(TaggingPresetTesterAction.java:49)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1664)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:285)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:247)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2928)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2920)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
	at java.awt.Component.processEvent(Component.java:5885)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4469)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1881)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:749)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1025)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:892)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:713)
	at java.awt.Component.dispatchEventImpl(Component.java:4339)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4295)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (1)

josm-error.png (21.5 KB) - added by tijuca 8 years ago.
error message of the plugin tagging-preset-tester

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by tijuca

Attachment: josm-error.png added

error message of the plugin tagging-preset-tester

comment:1 Changed 8 years ago by tijuca

Description: modified (diff)

comment:2 Changed 8 years ago by stoecker

You use an image "empty.png" in your new preset and don't supply the relevant image I would assume?

Thought the plugin must be fixed nevertheless, so it does display a proper warning instead of this error.

comment:3 Changed 8 years ago by tijuca

The idea with that warned picture I allready figured out. No, I don't have a named picture like "empty.png". But my used preset is a little bit bigger.

The complete preset will be found daily updated on https://github.com/tijuca/josm-presets

I work very offen on this preset for later use on tagging public transport, so this plugin whould be very helpfull for me to test out the preset.

carsten@q9550-squeeze64:~/gitprojects/josm-presets$ grep -i "empty.png" oepnv_preset_de-JES.xml 
carsten@q9550-squeeze64:~/gitprojects/josm-presets$ grep -i "bus.png" oepnv_preset_de-JES.xml 
        <group name="Public Transport" de.name="ÖPNV" icon="presets/bus.png">
carsten@q9550-squeeze64:~/gitprojects/josm-presets$ du -b *.xml
24406   oepnv_preset_de-JES.xml

The plugin seems to work like it should if I use a absolutly simple preset like this (taken from the wiki and cutted really small):

carsten@q9550-squeeze64:~/Dokumente$ cat test-preset.xml
<?xml version="1.0" encoding="UTF-8"?>
<presets xmlns="http://josm.openstreetmap.de/tagging-preset-1.0">
  <group name="Highways" icon="presets/way_secondary.png">
        <item name="Motorway" icon="presets/motorway.png" type="way">
            <link href="http://wiki.openstreetmap.org/wiki/Tag:highway=motorway"
                  de.href="http://wiki.openstreetmap.org/wiki/DE:Tag:highway=motorway" />
            <label text="Edit Motorway" />
            <space />
            <key key="highway" value="motorway" />
            <text key="ref" text="Reference" default="" delete_if_empty="true" />
        </item>
    </group>
</presets>

comment:4 Changed 8 years ago by simon04

Resolution: needinfo
Status: newclosed

Is this ticket still relevant?

comment:5 Changed 8 years ago by stoecker

Resolution: needinfo
Status: closedreopened

Yes, I think so. It should load pictures with getIfAvailable() instead of get() and print proper warning.

Please don't use needinfo and close. When a ticket is closed, then nobody cares afterwards anymore.

comment:6 Changed 8 years ago by simon04

Ticket #6619 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by skyper

Ticket #7013 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by skyper

Cc: FrViPofm added
Description: modified (diff)

comment:9 Changed 6 years ago by Don-vip

Component: PluginPlugin tagging-preset-tester
Keywords: tagging-preset-tester plugin removed

comment:10 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Fixed in [o29725].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.