Modify

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5795 closed defect (duplicate)

Plugin remotecontrol: load_and_ zoom: displaced zoom view if data already loaded

Reported by: werner2101 Owned by: framm
Priority: normal Milestone:
Component: Core remotecontrol Version: latest
Keywords: Cc:

Description (last modified by simon04)

When I load an area with load_and_zoom command and the data is already loaded then two things are happening:

  • An error dialog in german: "Fehler beim Herunterladen"; "In diesem Gebiet wurden keine Daten gefunden" freely translated: "Error while downloading"; "No data in this area"
  • after clicking the o.k. Button the zoom area is not the same as requested. It's displaced.

Steps to reproduce:
Load the same area twice e.g.

wget "http://localhost:8111/load_and_zoom?left=8.302&right=8.303&top=47.001&bottom=47.000"
wget "http://localhost:8111/load_and_zoom?left=8.302&right=8.303&top=47.001&bottom=47.000"

The second time the dialog is raised and the zoom view is wrong.

In my opion the dialog should not be raised at all. I think the error message is missleading as there is data in the downloaded area, it's just already present in josm.

My environment:

josm version: 3750
OS: Linux (SuSE 11.3)

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by simon04

Description: modified (diff)
Resolution: duplicate
Status: newclosed

No more open remotecontrol tickets. :-)

comment:2 Changed 8 years ago by simon04

Ticket #5795 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by simon04

Closed as duplicate of #5795.

comment:4 Changed 8 years ago by simon04

Resolution: duplicate
Status: closedreopened

Ups …

comment:5 Changed 8 years ago by simon04

Resolution: duplicate
Status: reopenedclosed

comment:6 Changed 8 years ago by simon04

Closed as duplicate of #2410.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.