Modify

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#2410 closed enhancement (fixed)

remotecontrol - not download data from server with every request

Reported by: fatbozz Owned by: framm
Priority: major Milestone:
Component: Core remotecontrol Version: latest
Keywords: Cc: bomm

Description (last modified by simon04)

Hello,
Ive found great checking tool to correct OSM mistakes. http://keepright.ipax.at/report_map.php this tool works with JOSM via remotecontrol plugin. Great coop, but is annoying to wait for every request to download data.

I suggest to compare request to actual bounding box in josm and then decide : is really need to download this another bbox again ?

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by stoecker

Component: PluginCore remotecontrol
Owner: changed from team to framm

comment:2 Changed 10 years ago by bastiK

Cc: bomm added

comment:3 Changed 8 years ago by xeen

Resolution: worksforme
Status: newclosed

as far as I can tell, this is already implemented. I tried it with openstreetbugs and JOSM does not re-download already available areas. If you have a specific case where it doesn’t work, please reopen the ticket and ideally provide links :)

comment:4 Changed 8 years ago by simon04

Description: modified (diff)

This is not fixed (completely), e.g., the following request triggers a download every time:

I assume, there is some rounding error …

comment:5 Changed 8 years ago by xeen

Resolution: worksforme
Status: closedreopened

Indeed it is. Fix is pretty easy though…

comment:6 Changed 8 years ago by xeen

Resolution: fixed
Status: reopenedclosed

In 4944/josm:

fix #2410

comment:7 Changed 8 years ago by simon04

Ticket #5795 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.