Modify

Opened 11 years ago

Closed 11 years ago

#5752 closed defect (fixed)

validator: warning window on upload is broken

Reported by: Cobra Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

The dialog warning you of errors in data you're going to upload is broken, see attached screenshot.
That renders the whole check before uploading quite useless.

Attachments (2)

JOSM Validator warning broken.png (8.7 KB) - added by Cobra 11 years ago.
JOSM Bug 5752.osm (954 bytes) - added by Cobra 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by Cobra

comment:1 Changed 11 years ago by bastiK

Does it look like this each time you have a warning for upload? What are the warnings? (See validator toggle dialog) What is your environment? (Help > Status Report)

comment:2 Changed 11 years ago by Cobra

This happens every time when there are any warnings.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-17 02:31:34
Last Changed Author: bastiK
Revision: 3730
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-16 18:20:22 +0100 (Thu, 16 Dec 2010)
Last Changed Rev: 3730

Identification: JOSM/1.5 (3730 en)
Memory Usage: 490 MB / 888 MB (45 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: PicLayer (24308)
Plugin: alignways (23560)
Plugin: measurement (22547)
Plugin: openstreetbugs (23747)
Plugin: openvisible (21706)
Plugin: reverter (23278)
Plugin: terracer (24713)
Plugin: undelete (22365)
Plugin: utilsplugin2 (24236)

comment:3 Changed 11 years ago by Cobra

This seems to happen even when there are no warnings.

I just selected all modified items (by using search for 'modified') and ran validator manually with no warnings/errors but the same thing happened again.

comment:4 Changed 11 years ago by Cobra

I investigated a bit further and checked all modified objects manually before uploading.

The dialog "collapses" only when there are no warnings (which means that it shouldn't show up at all…).

comment:5 Changed 11 years ago by bastiK

cannot reproduce. please append a *.osm file that triggers this bug on upload.

comment:6 Changed 11 years ago by Cobra

This seems to be related to buildings sharing some nodes. The attached file results in said behaviour.

Changed 11 years ago by Cobra

Attachment: JOSM Bug 5752.osm added

comment:7 Changed 11 years ago by bastiK

Using 3740, i still cannot reproduce:

  • open the file you attached
  • click upload
  • upload window is shown

Please make sure your file really shows this behaviour.

You could also add your settings. (Help > status report)

comment:8 Changed 11 years ago by Cobra

It's the setting
validator.otherUpload=true
which causes this. When I set this to false (which is the default according to the tooltip), the issue won't occur.

In combination with
validator.other= (unset, so default/false)
the strange situation occurs that there are no errors visible when checking manually.

Last edited 11 years ago by Cobra (previous) (diff)

comment:9 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

In [3742/josm]:

fixed #5752 - validator: warning window on upload is broken

comment:10 Changed 11 years ago by stoecker

Resolution: fixed
Status: closedreopened

No. This fix is false I assume. It again enables rendering of other warnings in normal dialog. I think correct would be to disable OTHER_UPLOAD in case OTHER is not enabled as well, so the dialog does not come up at all when other warnings aren't enabled.

comment:11 Changed 11 years ago by bastiK

Ticket #5780 has been marked as a duplicate of this ticket.

comment:12 Changed 11 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

In [3745/josm]:

fixed #5752 - validator: warning window on upload is broken (2)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.