Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5736 closed defect (duplicate)

Press Q after Shift+J

Reported by: ht.blumrich@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. two squares were build with Plugin BuildingTools
  2. Shift+J to merge both shapes
  3. Press Q to make the polygon rectengular ... This did chrash

Note: afer unselect and newly select Q did work

What is the expected result?
make a rectangular polygon

What happens instead?
Error Message pop up: Programming error ... please send a report

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-07 02:31:23
Last Changed Author: bastiK
Revision: 3701
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-06 21:19:45 +0100 (Mon, 06 Dec 2010)
Last Changed Rev: 3701

Identification: JOSM/1.5 (3701 de)
Memory Usage: 80 MB / 247 MB (25 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: RoadSigns (22850)
Plugin: buildings_tools (23804)
Plugin: imagery (24675)
Plugin: mapdust (24514)
Plugin: openstreetbugs (23747)
Plugin: remotecontrol (22734)

java.lang.NegativeArraySizeException
	at org.openstreetmap.josm.actions.OrthogonalizeAction$WayData.calcDirections(OrthogonalizeAction.java:408)
	at org.openstreetmap.josm.actions.OrthogonalizeAction.orthogonalize(OrthogonalizeAction.java:240)
	at org.openstreetmap.josm.actions.OrthogonalizeAction.actionPerformed(OrthogonalizeAction.java:183)%0


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-07 02:31:23
Last Changed Author: bastiK
Revision: 3701
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-06 21:19:45 +0100 (Mon, 06 Dec 2010)
Last Changed Rev: 3701

Identification: JOSM/1.5 (3701 de)
Memory Usage: 80 MB / 247 MB (25 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: RoadSigns (22850)
Plugin: buildings_tools (23804)
Plugin: imagery (24675)
Plugin: mapdust (24514)
Plugin: openstreetbugs (23747)
Plugin: remotecontrol (22734)

java.lang.NegativeArraySizeException
	at org.openstreetmap.josm.actions.OrthogonalizeAction$WayData.calcDirections(OrthogonalizeAction.java:408)
	at org.openstreetmap.josm.actions.OrthogonalizeAction.orthogonalize(OrthogonalizeAction.java:240)
	at org.openstreetmap.josm.actions.OrthogonalizeAction.actionPerformed(OrthogonalizeAction.java:183)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by anonymous

Possibly duplicate of #5728

comment:2 Changed 11 years ago by jttt

Resolution: duplicate
Status: newclosed

comment:3 Changed 11 years ago by anonymous

Closed as duplicate of #5728.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.