Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5728 closed defect (fixed)

[PATCH] Rectifying newly-merged polygons

Reported by: Larry0ua Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: JoinAreaAction, patch Cc:

Description

Hi,

I experience the bug that is always reproducible for me for every versions before (at least last 3 months).

  1. Draw two polygons and merge them with Shift+J
  2. Press Q to Ortho newly created polygon.
  3. See the exception.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-12-08 02:31:28
Last Changed Author: bastiK
Revision: 3706
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-12-07 12:49:44 +0100 (Tue, 07 Dec 2010)
Last Changed Rev: 3706

Identification: JOSM/1.5 (3706 en)
Memory Usage: 44 MB / 247 MB (15 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: DirectUpload (24239)
Plugin: ElevationProfile (24034)
Plugin: FixAddresses (24232)
Plugin: OpeningHoursEditor (24290)
Plugin: PicLayer (24308)
Plugin: alignways (23560)
Plugin: buildings_tools (23804)
Plugin: download_along (22427)
Plugin: editgpx (23659)
Plugin: imagery (24624)
Plugin: lakewalker (21706)
Plugin: public_transport (22148)
Plugin: remotecontrol (22734)
Plugin: restart (24396)
Plugin: terracer (22169)
Plugin: wayselector (23103)
Plugin: wmsplugin (24223)

java.lang.NegativeArraySizeException

at org.openstreetmap.josm.actions.OrthogonalizeAction$WayData.calcDirections(OrthogonalizeAction.java:408)
at org.openstreetmap.josm.actions.OrthogonalizeAction.orthogonalize(OrthogonalizeAction.java:240)
at org.openstreetmap.josm.actions.OrthogonalizeAction.actionPerformed(OrthogonalizeAction.java:183)
at javax.swing.SwingUtilities.notifyAction(Unknown Source)
at javax.swing.JComponent.processKeyBinding(Unknown Source)
at javax.swing.KeyboardManager.fireBinding(Unknown Source)
at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
at javax.swing.JComponent.processKeyBindings(Unknown Source)
at javax.swing.JComponent.processKeyEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

error.txt (3.1 KB) - added by Larry0ua 11 years ago.
error log
joinarea-setselection.patch (962 bytes) - added by KalleLampila 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Larry0ua

Attachment: error.txt added

error log

Changed 11 years ago by KalleLampila

Attachment: joinarea-setselection.patch added

comment:1 Changed 11 years ago by KalleLampila

Keywords: JoinAreaAction patch added
Summary: Rectifying newly-merged polygons[PATCH] Rectifying newly-merged polygons

This error is caused that selection is invalid after JoinAreaAction. Patch in attachment.

comment:2 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

In [3717/josm]:

fixed #5728 (patch by Larry0ua) - Rectifying newly-merged polygons

comment:3 Changed 11 years ago by KalleLampila

Btw I sent the patch not Larry0ua.

comment:4 Changed 11 years ago by bastiK

Oops. I was somewhat angry when that happened to me, now i'm doing it too... sorry. I'll be more careful.

comment:5 Changed 11 years ago by Larry0ua

Thanks you a lot for quick answer and patch :)

comment:6 Changed 11 years ago by anonymous

Ticket #5736 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.