Modify

Opened 9 years ago

Closed 2 years ago

#5676 closed defect (fixed)

edit summary (changeset comment) in upload dialog sometimes still uses old value

Reported by: stw1701 Owned by: michael2402
Priority: critical Milestone: 17.05
Component: Core Version: tested
Keywords: upload dialog changeset comment Cc: jinalfoflia, Thib, dido

Description (last modified by Don-vip)

When entering a new text in the "brief comment" field in the upload dialogue, sometimes the old value is still used and sent to the server.

This is hard to reproduce even for me, but I think it has something to do with the way Java registers changes in the checkbox. I'd have to press Return two or three times to get it right. Interesting thing is that the new value still shows up when I open the dialogue again.

Version 3592

Attachments (0)

Change History (8)

comment:1 in reply to:  description Changed 9 years ago by stw1701

Alright, just tried various methods of entering text in that field. To reproduce follow these steps:

  1. change something
  2. press upload
  3. enter some new text, overwriting an old value, don't press Return!
  4. click on the "Upload Changes" button

Results:

  • changes are upload to the server
  • change comment is set to the old value
  • next time the upload dialogue is opened, the new value is shown

Expected results:

  • changes are upload
  • change comment is set to the new value

comment:2 Changed 3 years ago by Don-vip

Description: modified (diff)
Keywords: dialog changeset comment added; dialogue removed
Priority: minorcritical
Summary: edit summary in upload dialogue sometimes still uses old valueedit summary (changeset comment) in upload dialog sometimes still uses old value

comment:3 Changed 3 years ago by Don-vip

Ticket #13270 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Don-vip

Ticket #14233 has been marked as a duplicate of this ticket.

comment:5 Changed 3 years ago by Don-vip

Ticket #14316 has been marked as a duplicate of this ticket.

comment:6 Changed 3 years ago by Don-vip

Cc: jinalfoflia Thib dido added

comment:7 Changed 2 years ago by michael2402

Milestone: 17.05
Owner: changed from team to michael2402
Status: newassigned

comment:8 Changed 2 years ago by michael2402

Resolution: fixed
Status: assignedclosed

In 12265/josm:

Fix #5676: Force a reload of the edit summary field if the user uploads data.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain michael2402.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.