Opened 8 years ago

Closed 8 years ago

#5485 closed defect (fixed)

nullpointer exception when downloading plugin list

Reported by: sanderd17 Owned by: team
Priority: blocker Milestone:
Component: Plugin Version:
Keywords: nullpointer, plugin Cc:


Maybe a double post. Quite agressive error.

What steps will reproduce the problem?

  1. open the preferences window in JOSM
  2. go to plugins and refresh the list
  3. Instead of refreshing, the list gets empty and you get the attached error.
Repository Root:
Build-Date: 2010-09-06 01:31:24
Last Changed Author: stoecker
Revision: 3514
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Date: 2010-09-05 23:03:46 +0200 (Sun, 05 Sep 2010)
Last Changed Rev: 3514

Identification: JOSM/1.5 (3514 nl)
Memory Usage: 133 MB / 672 MB (67 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Plugin: PicLayer
Plugin: routes
Plugin: turnrestrictions
Plugin: validator
Plugin: walkingpapers

	at org.openstreetmap.josm.plugins.PluginInformation.scanManifest(
	at org.openstreetmap.josm.plugins.PluginInformation.<init>(
	at org.openstreetmap.josm.plugins.PluginListParser.createInfo(
	at org.openstreetmap.josm.plugins.PluginListParser.parse(
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.processLocalPluginInformationFile(
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanSiteCacheFiles(
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanLocalPluginRepository(
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.realRun(
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(
	at java.util.concurrent.Executors$
	at java.util.concurrent.FutureTask$Sync.innerRun(
	at java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.util.concurrent.ThreadPoolExecutor$

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by bastiK

Ticket #5486 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by bastiK

Ticket #5487 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.