Modify

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#5387 closed defect (fixed)

lack of reprojection and server configuration difficulties (WAS: Wallonie WMS server and JOSM : compatibility and features)

Reported by: A_Pirard Owned by: A_Pirard
Priority: critical Milestone:
Component: Plugin proj4j Version: latest
Keywords: Cc: A_Pirard

Description (last modified by A_Pirard)

This is a great world, to live in & draw, but it had better stay flat as they thought it was ;-)

http://cartographie.wallonie.be hosts very nice WMS servers.
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?
and maybe better yet according to GetCapabilities:
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/portail?version1.1.1&
And ... <Fees>none</Fees> <AccessConstraints>none</AccessConstraints> !!!

Merkaartor uses the following requests and displays nice photographs:
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1
&REQUEST=GetMap&TRANSPARENT=TRUE&
LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7
&SRS=EPSG:31370&STYLES=&FORMAT=image/png
&WIDTH=673&HEIGHT=771&BBOX=... (in southern Belgium)

Hence, I tried the following URLs with JOSM 3376 (with portail and PPNC):
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/portail?&VERSION=1.1.1&SERVICE=WMS
&REQUEST=GetMap&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7
&SRS=EPSG:31370&STYLES=&FORMAT=image/png&

These requests execute without errors, but the map layer is all painted in black or white depending on the presence or absence of &TRANSPARENT=TRUE.

Have I missed some nice to reveal parameter or does JOSM need a fix or improvement?

There is a description of other elements like rivers & buildings in /portail?GetCapabilities
How can they be displayed??

As the map is dragged up and down, Merkaartor produce a severe, growing mismatch (offset) between OSM and Wallonie WMS data.
Is it because EPSG:31370 is used for the WMS layer?
Is it avoidable with Merkaartor?
Can JOSM be free from that defect?
Wallonie WMS GetCapabilities seems to announce EPSG:4326 capability, but it does not seem to work in a request.
Is it a bug in the server or what else is going on.

The day will be great when, like Merkaartor, JOSM will display the server capabilities to choose from instead of requiring to write an URL !!!

It's wonderful to think that the whole world is writing the map of the whole world and that the terrae incognitae like France will be discovered one day.

Feel free to ask any detail or data.

Keep the marvelous work !!! <thanks1, thanks2, thanks3, thanks1> !!!

André.

Attachments (1)

African_art.png (85.1 KB) - added by A_Pirard 8 years ago.

Download all attachments as: .zip

Change History (35)

comment:1 in reply to:  description Changed 9 years ago by bastiK

Replying to A_Pirard:

This is a great world, to live in & draw, but it had better stay flat as they thought it was ;-)

http://cartographie.wallonie.be hosts very nice WMS servers.
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?
and maybe better yet according to GetCapabilities:
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/portail?version1.1.1&
And ... <Fees>none</Fees> <AccessConstraints>none</AccessConstraints> !!!

This means nothing - have you read the full response? It says (c) Navtech. Please find reliable sources, that state, you can trace from their imagery, otherwise don't do it!

Merkaartor uses the following requests and displays nice photographs:
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1
&REQUEST=GetMap&TRANSPARENT=TRUE&
LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7
&SRS=EPSG:31370&STYLES=&FORMAT=image/png
&WIDTH=673&HEIGHT=771&BBOX=... (in southern Belgium)

Hence, I tried the following URLs with JOSM 3376 (with portail and PPNC):
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/portail?&VERSION=1.1.1&SERVICE=WMS
&REQUEST=GetMap&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7
&SRS=EPSG:31370&STYLES=&FORMAT=image/png&

These requests execute without errors, but the map layer is all painted in black or white depending on the presence or absence of &TRANSPARENT=TRUE.

Josm does not know the projection EPSG:31370 and consequently does send coordinates that are out of bound for their service. (You can always test such a URL in the browser!)

I'm curious, how Merkaartor finds the coordinates, however. They don't seem to have EPSG:31370 either.

Have I missed some nice to reveal parameter or does JOSM need a fix or improvement?

There is a description of other elements like rivers & buildings in /portail?GetCapabilities
How can they be displayed??

As the map is dragged up and down, Merkaartor produce a severe, growing mismatch (offset) between OSM and Wallonie WMS data.
Is it because EPSG:31370 is used for the WMS layer?
Is it avoidable with Merkaartor?

You should send a bug report to the Merkaartor team.

Can JOSM be free from that defect?

Yes.

Wallonie WMS GetCapabilities seems to announce EPSG:4326 capability, but it does not seem to work in a request.
Is it a bug in the server or what else is going on.

I think so.

comment:2 Changed 8 years ago by skyper

Component: unspecifiedCore imagery
Owner: changed from team to A_Pirard
Status: newneedinfo

Is there any new legal news ?

EPSG:31370 might go into another enhancement.

comment:3 Changed 8 years ago by skyper

Type: defectenhancement

comment:4 Changed 8 years ago by A_Pirard

Their e-mail address does not answer, neither about the legal aspect nor about their intention to correctly support EPSG:4326.
In fact, I asked "can I send a request?", they replied "go on" but they never replied to that request.
Please note that Belgian Merkaartor lists their server without any mention of copyright and they allow that.

In any case, having JOSM support EPSG:31370 has nothing to do with the legal aspect of one server or another.
If that were the case, EPSG:4326 wouldn't be supported :-)

Supporting Mercator and EPSG:31370 would be great !!!

What do you mean I'm "responsible" for that issue? I'm not responsible for anything !!!

Thanks.

comment:5 in reply to:  4 Changed 8 years ago by skyper

Replying to A_Pirard:

In any case, having JOSM support EPSG:31370 has nothing to do with the legal aspect of one server or another.
If that were the case, EPSG:4326 wouldn't be supported :-)

Supporting Mercator and EPSG:31370 would be great !!!

I thought the proj.4 plugin is supporting EPSG:31370 or am I wrong ?

comment:6 Changed 8 years ago by A_Pirard

Supporting Mercator and EPSG:31370 would be great !!!

I thought the proj.4 plugin is supporting or am I wrong ?

I thought the following meant I had to wait.

EPSG:31370 might go into another enhancement.

I've installed that cryptic proj.4 plugin and, indeed, EPSG:31370 is in it.
But the doc does not explain how to use it nor what to expect.
Proj4J states "Proj4J is a Java library to transform point coordinates from one geographic coordinate system to another, including datum transformations." That sounds like the coordinates of the server should be transformed to the coordinates that JOSM is using, isn't it, that is to WGS84=EPGS:4326.

But I still get the message that the server's EPSG:31370 does not match EPGS:4326 when I activate the following layer on top of OSM:
wms:http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&TRANSPARENT=TRUE&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7&SRS=EPSG:31370&STYLES=&FORMAT=image/png&

I can now change JOSM's system to EPSG:31370, but that certainly not how to support several additional layers with a coordinate mix, is it.
And if I do that, OSM no longer displays anything.

comment:7 Changed 8 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

You cannot display layers with different projection at once. JOSM does no reprojection. So as you say you need to switch to EPSG:31370 to work with these layers.

comment:8 in reply to:  7 Changed 8 years ago by A_Pirard

Description: modified (diff)

Replying to stoecker:

You cannot display layers with different projection at once. JOSM does no reprojection. So as you say you need to switch to EPSG:31370 to work with these layers.

But if I can't display them together with OSM, they can hardly be called layers, can they?

So, by "fixed", I suppose you mean using Merkaartor.

Thanks for your answer.

comment:9 Changed 8 years ago by stoecker

You cannot use two different projections at the same time! That should be pretty easy to understand.

Each layer in OSM supports different projections and you can only display layers at the same time, which support equal projections. The OSM data itself is vector data and supports all projections. So mainly the "combination" problem only appears when you want to use two raster data layers at the same time.

If you want to display raster data with a non-standard projection, then switch JOSM to THIS projection and load the layer.

But if you properly define your URL:

http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&TRANSPARENT=TRUE&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7&SRS={proj(EPSG:4326,EPSG:31370,EPSG:4267,EPSG:4269)}&STYLES=&FORMAT=image/png&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

you see, that this server supports a lot more than this one projection! And especially it supports EPSG:4326, which is the JOSM default.

comment:10 Changed 8 years ago by skyper

Any news on the legal situation ?

comment:11 Changed 8 years ago by A_Pirard

But if you properly define your URL:

http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&TRANSPARENT=TRUE&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7&SRS={proj(EPSG:4326,EPSG:31370,EPSG:4267,EPSG:4269)}&STYLES=&FORMAT=image/png&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

you see, that this server supports a lot more than this one projection!
And especially it supports EPSG:4326, which is the JOSM default.

I have already tested that definition too and anyone who tries it will see that it does not work.
Type this in a Web browser and you will see a all white picture:
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&TRANSPARENT=TRUE&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7&STYLES=&FORMAT=image/png&SRS=EPSG:4326&WIDTH=500&height=500&BBOX=5.6398962,50.5353262,5.6540312,50.5443096

But if you transform that to Belgian Lambert 72, you get the correct picture, corresponding to the above BBOX
http://cartopro1.wallonie.be/WMS/com.esri.wms.Esrimap/PPNC?version1.1.1&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&TRANSPARENT=TRUE&LAYERS=ppnc1,ppnc2,ppnc3,ppnc4,ppnc5,ppnc6,ppnc7&STYLES=&FORMAT=image/png&SRS=EPSG:31370&WIDTH=500&HEIGHT=500&BBOX=240110.293,136836.141,241094.878,137852.506

4326 does *not* work (server's fault is to announce it).
And I think that 4267 and 4269 don't work either.
They don't even make sense, they're for North America.
Only 31370 works.
As I said above in this thread, it's a bug I reported to them and they don't reply (to any mail).

You cannot use two different projections at the same time! That should be pretty easy to understand.

Not easy to understand at all !!! All I could find as Help for this is:

http://josm.openstreetmap.de/wiki/Help/Preferences/Map

Map Projection
You can change the map projection method between Mercator, and some others. Be aware that projections maybe only valid for a certain area of the world.

Changes "map projection", of course, OK, but which? No restrictions.
I updated that doc to the best of my understanding of what you say.

Furthermore, http://josm.openstreetmap.de/wiki/Help/Concepts/Coordinates seems to explain that maps are transformed to the screen from any coordinate system. I posted a warning in that article.

Proj4J is a Java library to transform point coordinates from one geographic coordinate system to another, including datum transformations.

and such a "datum transformation" looks like the simple "perspective" transformation of GIMP.

If you want to display raster data with a non-standard projection, then switch JOSM to THIS projection and load the layer.

I thought that EPSG:31370 is a standard.
I suppose that "switch JOSM" means set Edit/Preference/WMS/Projection to Proj4J:EPSG:31370, I did.
My OSM view changed from previous Belgian map to entire black.
Best bet was to use slippery map, it displayed near Bafwandese on RN4 off Kisangani (that's ex-Belgian Congo!!!)
I set the view back to Belgium and JOSM displayed the map I attached as African_art.png.
I tried the Wallonie PPNC overlay with both the definition you recommend and mine (forcing 31370). Both give a black map.
None of the other overlay that used to work works any longer.
In a word, if I try your recommendations, nothing works.
That is pretty easy to test.
What tests did you make to conclude that the problem is fixed?

Does that all mean that one should constantly change the projection preference according to the servers used?

As I explained from the start, with Merkaartor I just add layers for Wallonie PPNC, Bing and various other servers.
It happily combines layers of different projections.
Merkaartor implements a per server projection setting, but I have it work without using it.

Thanks for a great JOSM besides this!!! I'm annoyed to have to use Merkaartor instead.

Changed 8 years ago by A_Pirard

Attachment: African_art.png added

comment:12 Changed 8 years ago by A_Pirard

Resolution: fixed
Status: closedreopened

comment:13 Changed 8 years ago by stoecker

Component: Core imageryPlugin proj4j

Please do not use the wiki pages as support channel. The wiki is to state information, not to request help.

What do you want we should do? It seems you have a broken WMS service. We can't fix this. If this service announces it supports certain projections and it does not and none of the projections works, what should be do about it?

The projection EPSG:31370 seems not to work, so probably pro4j plugin is broken. I assign the ticket accordingly.

You again changed the URL. You MUST not change the URL so that it directly includes a projection. It is described at the wiki pages you modified as well as above. Raster images are in a certain projection. JOSM needs to use the projection. So you simply need to set ONE of the projections supported by the server in JOSM. The list of projections in the URL is than matched against this and when the server supports the code, then requests are sent accordingly. If not, then you get a warning.

If you modify that by hand and then access the data, you f.e. send requests with coordinates in one system, but request another. This must fail in any case.

and such a "datum transformation" looks like the simple "perspective" transformation of GIMP.

No, such datum transformation is a very complex process. Only the simplest cases are perspective transformations.

Does that all mean that one should constantly change the projection preference according to the servers used?

Yes sure. We have no raster-reprojection. If you want a full-featured GIS, use one and not JOSM. If merkaartor does what you want, why not use it. Merkaartor uses proj4 library, we can't do this from josm's java core.

comment:14 in reply to:  11 Changed 8 years ago by bastiK

Replying to A_Pirard:

I thought that EPSG:31370 is a standard.
I suppose that "switch JOSM" means set Edit/Preference/WMS/Projection to Proj4J:EPSG:31370, I did.
My OSM view changed from previous Belgian map to entire black.

Try with the latest version of the proj4j plugin, it should work now. (In [o27902])

comment:15 in reply to:  13 Changed 8 years ago by bastiK

Replying to stoecker:

Yes sure. We have no raster-reprojection. If you want a full-featured GIS, use one and not JOSM. If merkaartor does what you want, why not use it. Merkaartor uses proj4 library, we can't do this from josm's java core.

See #7427.

comment:16 Changed 8 years ago by skyper

Status: reopenedneedinfo

comment:17 Changed 8 years ago by stoecker

The plugin proj4j ist still broken. Without proper boundaries JOSM is not able to zoom properly and this makes working impossible. If proj4j does not offer boundaries, then at least the projection dialog should allow to specify them by hand.

comment:18 Changed 8 years ago by stoecker

Also if I display the map and go to download dialog, then area matches. But when I did download data, then it does not appear in the right position over the map. Seems one of the coordinate transformations is broken. Works with ESPG:4326 and ESPG:3857.

comment:19 Changed 8 years ago by skyper

Owner: changed from A_Pirard to team
Priority: normalcritical
Status: needinfonew
Summary: Wallonie WMS server and JOSM : compatibility and featuresBroken transformation + offer boundaries (WAS: Wallonie WMS server and JOSM : compatibility and features)
Type: enhancementdefect

comment:21 Changed 8 years ago by A_Pirard

Yes sure. We have no raster-reprojection. If you want a full-featured

GIS, use one and not JOSM. If merkaartor does what you want, why not use
it. Merkaartor uses proj4 library, we can't do this from josm's java cor
See #7427

Please do not change the subject of my Ticket which turned to be mixing raster servers.
Please avoid if possible opening a second ticket #7427 for the same purpose.
Please open another ticket for EPS:3170 etc support matters.
So that my description and subsequent discussion continue to make sense.

Why not using Merkaartor or FF? Because I love JOSM, what you do and what I can do .

More comments will follow.

comment:22 Changed 8 years ago by A_Pirard

On 2012-02-20 11:56, JOSM wrote :

I suppose that "switch JOSM" means set Edit/Preference/WMS/Projection to

Proj4J:EPSG:31370, I did.

My OSM view changed from previous Belgian map to entire black.

Try with the latest version of the proj4j plugin, it should work now. (In
[o27902])

With 27902, as compared with my previous report:

  • switching the map to 31370 no longer blackens OSM, it continues to display correct data
  • the slipping map now stays on the current view
  • but reloading the same view blackens the window, the OSM data displays elsewhere and is distorted
  • when dragging to view it, it's in a striped area, not black one.
  • Initially loading an area is correct until you try to load more but the black area turns to stripes as you move the mouse over it.

I'll continue testing this issue without reloading data until better.

comment:23 Changed 8 years ago by A_Pirard

I have opened Ticket #7444 for the proj4 matter and I will copy more of my comments to there this afternoon if possible)

comment:24 Changed 8 years ago by Don-vip

In 5022/josm:

see #5387, #7444 - Add Belgian Lambert 1972 (EPSG:31370) and Belgian Lambert 2008 (EPSG:3812) projections

comment:25 Changed 8 years ago by bastiK

Owner: changed from team to A_Pirard
Status: newneedinfo

@A_Pirard: Please test with the new projection added by Don-vip (no plugin needed).

comment:26 Changed 8 years ago by A_Pirard

Why did I receive e-mail for #5387:25 but not :24 and #7444:4 and other comments?
# Owner changed from team to A_Pirard ???
Owner — Principal person responsible for handling the issue ??????
handling ????????? what the heck does that mean? much unclear place.
I'm reporting and helping the best I can but I'm in charge of nothing here.

I had some time and I comment the 5022 tests in #7444.

Last edited 8 years ago by A_Pirard (previous) (diff)

comment:27 Changed 8 years ago by A_Pirard

Summary: Broken transformation + offer boundaries (WAS: Wallonie WMS server and JOSM : compatibility and features)lack of reprojection and server configuration difficulties (WAS: Wallonie WMS server and JOSM : compatibility and features)

comment:28 Changed 7 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

Reprojection is another ticket.

comment:29 Changed 7 years ago by A_Pirard

Reprojection has moved to another ticket indeed, but the server configuration issues remain the same user difficulties

In short,

1) I was scolded because I was using a bad server config.
But that config had been automatically made by JOSM: &SRS={proj}
So, JOSM should make correct configs to prevent scoldering users.

Please note that when JOSM will reproject, selecting the server projection by the user will be needed.
Please have a look at Merkartoor's server configuration.

2) I did not find the format of that server config in the doc (esp. &SRS), I used guessing

3) I did not find documentation (at least clearly) that

  • the setting called "the projection" should be called "the screen projection" to be understandable
  • that it should be Mercator for best results
  • that server projections must be modified = reprojected to that of the screen
  • that JOSM cannot reproject raster scan (yet)

4) so, I'm very thankful to those, especially stoeker, who helped me find all that

5) and I tried to be helpful by adding to the doc what I knew I had been missing, in generally understandable terms, but most of what I wrote was changed without notice, for example that one should have a look at OSM documentation after learning JOSM instead of before (notice that the JOSM introduction does not even say that JOSM is used to draw a map), or that the default projection is Merkaartor (sic). It's not a default it's a recommendation and it would be best to explain why.

For example, this presumes that you know several terms and concepts:

When you use rasterized background imagery then you need to set a projection supported by the service providing this imagery. JOSM is not able to change raster images. When image projection and current settings do not match, you get warned.

while the followng requires less knowledge:

JOSM must convert the projection of maps provided by the servers to the projection of the screen. It is presently able to convert (reproject) only vector images. Hence, the screen projection must be set to one of the possible projections of the servers' raster images and all such images (from all servers) must use the same projection. JOSM issues a warning when the screen projection does not belong in a server's projection list.

comment:30 Changed 7 years ago by A_Pirard

In conclusion, the "difficulties" issue is still the same.
I leave it up to you whether to keep this case open, start a cleaner one or disregard that problem.

comment:31 Changed 7 years ago by stoecker

I don't understand your point 1. &SRS={proj} is correct.

2 and 3: Maps

For the other points:

In think you have an understanding problem here. Projection in our context means to display earth related data on a flat display. There are different ways to do so, all of them have advantages and disadvantages (called the projections). JOSM's default is Mercator, as this is what most users expect the earth should look like (e.g. a circle is a circle in Mercator). Everytime we display some (vector) data, it is projected using the preferences setting.

Now for raster images situation is different. These already have been projected by someone else. We can only display them. To work reliable this requires that all other displays in JOSM also use the same projection of the raster data. An additional feature (reprojection) is that we could recalculate and modify the raster images so that they match another projection selected in JOSM. This is a non-trivial task and in nearly any case reduces the quality. Probably somewhen a plugin will supply that feature.

We have a workaround that EPSG:4326, the most common set in WMS servers is also displayed when Mercator in JOSM is choosen. Technically this is wrong, but for usable zoom levels the error is not really relevant.

What we can do is automatically select a correct projection when a WMS is loaded and go back to settings when closed. I believe this is another ticket as well. Some basic support has already been implemented for this.

comment:32 in reply to:  31 ; Changed 7 years ago by A_Pirard

Replying to stoecker:

I don't understand your point 1. &SRS={proj} is correct.

{proj} does work but you once wrote:

But if you properly define your URL:

... SRS={proj(EPSG:4326,EPSG:31370,EPSG:4267,EPSG:4269)}...

If that's the proper way, that's the way automatic configuration should use, not the user.

It will be the mandatory way when reprojection will work and will have to choose one projection.
The user must be able to indicate which one(s) to select (remember one of these isn't working for that server).

you see, that this server supports a lot more than this one projection!

No, the user doesn't see that when JOSM shows him {proj}.
He must understand how to display capabilities.

2 and 3: Maps

Not, I'm afraid.

In think you have an understanding problem here.

I have no understanding problem about the working of projections and I wonder what in what I said makes you believe that. I am trying to explain that a novice user may not understand the explanations at all or the same way as the one who wrote them. For example "automatically select a correct projection" can be not understood if not saying of what that projection is.
When I was a novice, I wondered for a long time what what you call "the projection" is until I understood it's the screen projection.

JOSM should always reproject (or project) every data to Mercator on the screen. Changing the screen's projection instead can only work if all raster sources use the same projection and it's a pain to constantly have to change them to use other servers.

I have shown in Ticket #7427 a picture of Bing tiles displayed on a Lambert screen projection. It means that the Lambert coordinates are translated to EPSG:4326. No data transformation. They look approximatively correct and I found them very usable. I would have appreciated translating the Lambert coordinates instead.

Presently I'm using techniques external to JOSM, you know what I mean, but as I'm far from selfish, I'd like this reprojection to work for many to use with as little as possible to have to understand. Thanks!

comment:33 in reply to:  32 Changed 7 years ago by stoecker

Hello,

... SRS={proj(EPSG:4326,EPSG:31370,EPSG:4267,EPSG:4269)}...

If that's the proper way, that's the way automatic configuration should use, not the user.

No. That is only required, when you define the URL by hand. If you use JOSM interface, then JOSM copies the supported projections as hidden data set (like attribution, icon, ...) equal to the way the Maps page is working. The imagery interface does not expose all information JOSM has about an imagery server. Easiest way is still to use a XML file describing the imagery source and load that as additional source information. If freely usable adding it to Maps page is easiest.

But remember: Adding own servers not in Maps page is not a thing a normal users does. So I have no problem with the fact this is somewhat more complex. Actually this encourages to use our source description interface. I have e.g. a secondary non-public source interface, where I keep lots of additional services.

2 and 3: Maps

Not, I'm afraid.

What are you missing? At the end all URL parameters are described. We don't describe WMS itself thought.

In think you have an understanding problem here.

I have no understanding problem about the working of projections and I wonder what in what I said makes you believe that. I am trying to explain that a novice user may not understand the explanations at all or the same way as the one who wrote them. For example "automatically select a correct projection" can be not understood if not saying of what that projection is.

I doubt JOSM can fill in the gap here. It is a complex topic and when I studied projections took half a year. JOSM tries to make it easy to use, but there will always be the necessarity to understand the topic when leaving the default path.

JOSM should always reproject (or project) every data to Mercator on the screen. Changing the screen's projection instead can only work if all raster sources use the same projection and it's a pain to constantly have to change them to use other servers.

As said. That has drawbacks as well and is not an easy topic. E.g. The displayed tiles after reprojection can have any form and are no longer rectangular, which is a major issue.

I have shown in Ticket #7427 a picture of Bing tiles displayed on a Lambert screen projection. It means that the Lambert coordinates are translated to EPSG:4326. No data transformation. They look approximatively correct and I found them very usable. I would have appreciated translating the Lambert coordinates instead.

Probably Lambert also uses lat/lon as parameters, so that URLs work in principle. And if tiles are small enough you always will get a "approximatively correct".

Presently I'm using techniques external to JOSM, you know what I mean, but as I'm far from selfish, I'd like this reprojection to work for many to use with as little as possible to have to understand. Thanks!

I doubt we will have this in JOSM core ever, as very likely we need a large number of imports for the reprojection. Except someone has a very lightweight implementation based on JOSM's internal projection code.

comment:34 Changed 7 years ago by A_Pirard

Let us be short and practical.

If a full blown WMS->screen reprojection like Merkartoor does (with suspected bugs) is not possible, then just translating the screen->WMS tile coordinates like it is presently done with ->Bing is the thing to do. Plus maybe a simple trapeze->rectangle or like linear warping? Maybe just while waiting for a better solution.

Please note that changing the screen projection to avoid reprojecting some server obliges JOSM to reproject Bing, so better do with that server what is presently done with Bing.

Both solutions need that JOSM server configuration, self- or not, display the server projection list and that the user may choose one of them (to disable others).

In Preferences the user should be told that the "map" and its "projection" is what is displayed on screen and that Mercator is the preferred "projection" (not only the "factory" default) with little reason to be changed.

Then the general user will have little to learn about projections.

Thanks for a marvelous program.

comment:35 Changed 7 years ago by stoecker

That would introduce a bunch a troubles nobody wants. Either we do it correct or not at all. Merkaartor uses libproj4, so probably that could be an addition to the proj plugin.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain A_Pirard.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.