Modify

Opened 11 years ago

Closed 11 years ago

#530 closed defect (fixed)

"Change values" window obscured

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: Core Version:
Keywords: UI Cc:

Description

The modal Change values? dialog box can be obscured by the Properties/Memberships window if the Properties/Memberships window is undocked. Since Change values? is modal, none of the other JOSM windows can be activated, creating a very confusing user experience.

To recreate:

  1. Select an object (node or way) so that its properties appear in Properties/Memberships.
  2. Undock the Properties/Memberships window and center it on the screen.
  3. Select a property and click Edit.
  4. Note that neither the JOSM main window or the Properties/Memberships window can receive focus (because the modal Change values? dialog box is open, behind Properties/Memberships).
  5. Note that the user would be very confused at this point, because it seems as though all of the open windows are "locked up".
  6. Note that a user who thinks that the application is not responding would probably resort to terminating the process, losing their changes.

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by anonymous

Resolution: fixed
Status: newclosed

Should be fixed in newer version, at least I was unable to reproduce.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.