Modify

Opened 9 years ago

Closed 8 years ago

#5218 closed defect (fixed)

Validator does not know many relation-types

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: unknown relation type Cc:

Description (last modified by simon04)

Validator does not know type=site, associatedStreet, TMC, bridge and other either common used or approved relations-types. Instead you get a warning about an unknown relation-type.

r3362 , o22065

cu skyper

Attachments (0)

Change History (17)

comment:1 Changed 9 years ago by stoecker

Actually JOSM startup page already tells you about that fact. You can help by providing new entries or the relation presets menu.

comment:2 in reply to:  1 Changed 9 years ago by skyper

Replying to stoecker:

Actually JOSM startup page already tells you about that fact. You can help by providing new entries or the relation presets menu.

The way the presets work in JOSM right now, I rather clone an existing relation or manually create the relation, which is much faster than using presets.

comment:3 Changed 9 years ago by bundesrainer

I also get a warning from the validator for type=waterway, altough this entry is recognized in the relation view and translated to "Gewässer".
How exactly can I provide new entries for the relation presets menu?

comment:4 Changed 9 years ago by stoecker

See data/defaultpresets.xml. At the beginning is the description, ad the end the relations. Basically you need to specify a block which contains the tags and one with the roles of a relation:

Example for multipolygon:

        <item name="Multipolygon" icon="presets/empty.png" type="relation">
            <link href="http://wiki.openstreetmap.org/wiki/Relation:multipolygon"
                  de.href="http://wiki.openstreetmap.org/wiki/DE:Relation:multipolygon"
                  fr.href="http://wiki.openstreetmap.org/wiki/FR:Relation:multipolygon" />
            <label text="Edit Multipolygon" />
            <key key="type" value="multipolygon" />
            <optional>
                <text key="name" text="Name" default="" delete_if_empty="true" />
            </optional>
            <roles>
                <role key="outer" text="outer segment" requisite="required" type="way" />
                <role key="inner" text="inner segment" requisite="optional" type="way" />
            </roles>
        </item>

BTW: What a type of relation should "type=waterway" be?

comment:5 Changed 9 years ago by bundesrainer

Thanks. The waterway relation type is for rivers, canals:
http://wiki.openstreetmap.org/wiki/Relations/Proposed/Waterway

Though still a proposal it is already used for many rivers:
http://wiki.openstreetmap.org/wiki/WikiProject_Germany/Gew%C3%A4sser

comment:6 Changed 8 years ago by simon04

Ticket #6080 (Relation type Enforcement is unknown but it's official) has been marked as a duplicate of this ticket.

Last edited 8 years ago by simon04 (previous) (diff)

comment:7 Changed 8 years ago by simon04

Ticket #7044 (Do not warn about relations with role=house as member of associatedStreet) has been marked as a duplicate of this ticket.

Last edited 8 years ago by simon04 (previous) (diff)

comment:8 Changed 8 years ago by simon04

Description: modified (diff)

type=network and type=associatedStreet have been added in r3544.

comment:9 Changed 8 years ago by simon04

In [4651/josm]:

see #5218 - add several relation presets: type={site,enforcement,route_master,street,destination_sign,waterway}

comment:10 Changed 8 years ago by simon04

IMHO, TMC cannot be handled by a preset in JOSM as it requires varying keys (e.g. TMC:cid_58:tabcd_1:LocationCode=1234).

comment:11 Changed 8 years ago by simon04

In [4653/josm]:

see #5218 - add several relation presets: type={bridge,tunnel}

comment:12 Changed 8 years ago by simon04

If I see it correctly, from the frequent used relation types, there are (only) a few from the Oxomoa scheme missing (stop_area, stop_area_group, line, …).

Last edited 8 years ago by simon04 (previous) (diff)

comment:13 Changed 8 years ago by simon04

Ticket #6265 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by stoecker

These checkins should have waited until after release. Now the translations are incomplete again.

comment:15 Changed 8 years ago by simon04

Sorry … However, now the presets are more complete and the validator less falsely verbose. :-)

comment:16 in reply to:  12 ; Changed 8 years ago by skyper

Replying to simon04:

If I see it correctly, from the frequent used relation types, there are (only) a few from the Oxomoa scheme missing (stop_area, stop_area_group, line, …).

I was more concerned about common relations not about Oxomoa speciales.

I thought there is a plugin for this scheme.
Does Validator include values from plugins ?

Anyway, I think we can close this ticket and either reopen it or open a new ticket if it is needed.

Thanks.

comment:17 in reply to:  16 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

Replying to skyper:

Does Validator include values from plugins ?

As far as I know, the validator makes use of any active presets.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.