Modify

Opened 11 years ago

Closed 10 years ago

#5114 closed defect (irreproducible)

JOSM crash when zooming slippy map with scroll wheel

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Click on download data button
  3. Turn scrollwheel on mouse quickly to zoom in the slippy map

What is the expected result?
The slippy map should zoom in and out.

What happens instead?
I get an error message and a polite request to file a bug report.

Please provide any additional information below. Attach a screenshot if
possible.

If I use the scrollwheel slowly it seems there is no problem. If I move it too quickly I get one error message box per scrollwheel click. When I clear all the error message boxes the slippy map works- I can slide it around and shift-click to mark an area, however the slippy map image is 'blocky' because the image has been zoomed locally, but the new slippy map image has not been downloaded from the server. In this situation any scrollwheel movement causes another error message box to appear.

Build-Date: 2010-04-26 01:31:31
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Author: jttt
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Date: 2010-04-25 15:31:07 +0200 (Sun, 25 Apr 2010)
Last Changed Rev: 3208
Repository Root: http://josm.openstreetmap.de/svn
Revision: 3208

Memory Usage: 28 MB / 508 MB (4 MB allocated, but free)
Java version: 1.5.0, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP


Plugins: openstreetbugs,remotecontrol,validator,wmsplugin
Plugin validator (Version: 20799)
Plugin remotecontrol (Version: 19946)
Plugin wmsplugin (Version: 20891)
Plugin openstreetbugs (Version: 20696)

java.lang.NullPointerException
	at java.util.concurrent.LinkedBlockingQueue.extract(Unknown Source)
	at java.util.concurrent.LinkedBlockingQueue.poll(Unknown Source)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.executeJobs(JobDispatcher.java:113)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.run(JobDispatcher.java:98)

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by Cobra

Resolution: irreproducible
Status: newclosed

Can't reproduce with r4171.

comment:2 Changed 10 years ago by anonymous

Same bug in here.

It happens when i zoom too much fast over the map, if the scroll has been set too much sensitive and you go scroll too much fast, it crashes ...
I have a Logitech touch scroll mouse with has a touch pad instead of the scroll wheel if my finger moves a bit weird then i get the bug ...

It will not happen instanteanously, usually it is when JOSM begin to cash, when you use 2 maps layers like Bing and OSM for example in more than your drawing.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-08-01 01:31:34
Last Changed Author: stoecker
Revision: 4279
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-31 23:52:49 +0200 (Sun, 31 Jul 2011)
Last Changed Rev: 4279

Identification: JOSM/1.5 (4279 fr)
Memory Usage: 293 MB / 507 MB (119 MB allocated, but free)
Java version: 1.6.0_26, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X
Dataset consistency test: No problems found

Plugin: AddrInterpolation (26284)
Plugin: Curves (16.master-4f7c5a0)
Plugin: DirectDownload (26174)
Plugin: DirectUpload (26284)
Plugin: FixAddresses (26299)
Plugin: ImportImagePlugin (26452)
Plugin: ImproveWayAccuracy (26224)
Plugin: OpeningHoursEditor (26284)
Plugin: PicLayer (26509)
Plugin: RoadSigns (26401)
Plugin: alignways (26174)
Plugin: buildings_tools (26254)
Plugin: cadastre-fr (26330)
Plugin: contourmerge (1001)
Plugin: dataimport (26174)
Plugin: download_along (26174)
Plugin: epci-fr (26282)
Plugin: ext_tools (26284)
Plugin: imageryadjust (26174)
Plugin: importvec (26174)
Plugin: mapdust (26174)
Plugin: measurement (26174)
Plugin: openstreetbugs (26299)
Plugin: openvisible (26174)
Plugin: osmarender (26174)
Plugin: proj4j (26416)
Plugin: public_transport (26284)
Plugin: reltoolbox (26299)
Plugin: restart (26254)
Plugin: routes (26174)
Plugin: tageditor (26299)
Plugin: terracer (26174)
Plugin: touchscreenhelper (26174)
Plugin: turnlanes (26316)
Plugin: turnrestrictions (26299)
Plugin: undelete (26254)
Plugin: utilsplugin2 (26395)
Plugin: waydownloader (26174)

java.lang.ArithmeticException: Font transform has NaN position

at sun.font.AppleNativeStrike.getNativeGlyphOutline(Native Method)
at sun.font.AppleNativeStrike.getGlyphOutline(AppleNativeStrike.java:212)
at sun.font.StandardGlyphVector$GlyphStrike.appendGlyphOutline(StandardGlyphVector.java:1799)
at sun.font.StandardGlyphVector.getGlyphsOutline(StandardGlyphVector.java:1171)
at sun.font.StandardGlyphVector.getOutline(StandardGlyphVector.java:405)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawTextOnPath(MapPainter.java:318)
at org.openstreetmap.josm.gui.mappaint.LineTextElemStyle.paintPrimitive(LineTextElemStyle.java:33)
at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleCollector.drawAll(StyledMapRenderer.java:138)
at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:229)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:259)
at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:451)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:505)
at javax.swing.JComponent.paintChildren(JComponent.java:862)
at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
at javax.swing.JComponent.paint(JComponent.java:1038)
at javax.swing.JComponent._paintImmediately(JComponent.java:5098)
at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:811)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:713)
at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:693)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:125)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:677)
at java.awt.EventQueue.access$000(EventQueue.java:85)
at java.awt.EventQueue$1.run(EventQueue.java:638)
at java.awt.EventQueue$1.run(EventQueue.java:636)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:647)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

comment:3 Changed 10 years ago by anonymous

Resolution: irreproducible
Status: closedreopened
Version: tested

comment:4 Changed 10 years ago by rickmastfan67

Resolution: irreproducible
Status: reopenedclosed

Can't reproduce with r4317.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-08-14 01:32:17
Last Changed Author: bastiK
Revision: 4317
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-08-13 20:04:52 +0200 (Sat, 13 Aug 2011)
Last Changed Rev: 4317

Identification: JOSM/1.5 (4317 en)
Memory Usage: 122 MB / 3640 MB (90 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

comment:5 Changed 10 years ago by rickmastfan67

BTW "anonymous", you might not want to be running so many plugins at one time. That might be the reason for the crashing. Try disabling some and you might not have any problems.

comment:6 Changed 10 years ago by anonymous

But I am needing all these plug-ins! Why making plug-ins if not to use them?

I have de-activated all the plug-ins exepted one: WMS Imagery adjust.
Crashed again. So it is not related to the quantity of plug-ins you are using at the same time.

How to repdrodcue:

download datas. add a Bing imagery layer or whatever zoom, a bit on the map and move over the map till JOSM will load enough tiles and then begin to zoom fast in and out over your map, using a trackpad for example if you have a laptop, it will not take long for JOSM to crash.

And sorry, the bug is not closed you cannot close it like this just because you can't manage to reproduce it. It is easy to reproduce also, you didn't seriously try, it didn't take me more than 30 s to crash it when I try to do it.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-08-01 01:31:34
Last Changed Author: stoecker
Revision: 4279
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-07-31 23:52:49 +0200 (Sun, 31 Jul 2011)
Last Changed Rev: 4279

Identification: JOSM/1.5 (4279 fr)
Memory Usage: 206 MB / 507 MB (61 MB allocated, but free)
Java version: 1.6.0_26, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X
Dataset consistency test: No problems found

Plugin: imageryadjust (26174)

java.lang.ArithmeticException: Font transform has NaN position

at sun.font.AppleNativeStrike.getNativeGlyphOutline(Native Method)
at sun.font.AppleNativeStrike.getGlyphOutline(AppleNativeStrike.java:212)
at sun.font.StandardGlyphVector$GlyphStrike.appendGlyphOutline(StandardGlyphVector.java:1799)
at sun.font.StandardGlyphVector.getGlyphsOutline(StandardGlyphVector.java:1171)
at sun.font.StandardGlyphVector.getOutline(StandardGlyphVector.java:405)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawTextOnPath(MapPainter.java:318)
at org.openstreetmap.josm.gui.mappaint.LineTextElemStyle.paintPrimitive(LineTextElemStyle.java:33)
at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleCollector.drawAll(StyledMapRenderer.java:138)
at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:229)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:259)
at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:451)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:505)
at javax.swing.JComponent.paintChildren(JComponent.java:862)
at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
at javax.swing.JComponent.paint(JComponent.java:1038)
at javax.swing.JComponent._paintImmediately(JComponent.java:5098)
at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:811)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:713)
at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:693)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:125)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:677)
at java.awt.EventQueue.access$000(EventQueue.java:85)
at java.awt.EventQueue$1.run(EventQueue.java:638)
at java.awt.EventQueue$1.run(EventQueue.java:636)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:647)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

comment:7 Changed 10 years ago by anonymous

Resolution: irreproducible
Status: closedreopened

comment:8 Changed 10 years ago by bastiK

@anonymous: Your problem is unrelated to this ticket, please open another bug report. Also please note the Mappaint Styles you are using. It should only happen if you have text along way. Make Dataset consistency test or try different small areas, to make sure the problem is not related to corrupt data, like duplicate nodes in a way.

comment:9 Changed 10 years ago by bastiK

Resolution: irreproducible
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.