Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5032 closed defect (fixed)

Unexpected error during PASTE

Reported by: willis@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Copied two highways in one layer. When pasting them into another layer this error occurs. JOSM doesn't work anymore. After going back tp previously used version 3243 I can do the same without problem.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-05-16 01:31:47
Last Changed Author: jttt
Revision: 3256
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-05-15 22:10:06 +0200 (Sat, 15 May 2010)
Last Changed Rev: 3256

Memory Usage: 45 MB / 989 MB (5 MB allocated, but free)
Java version: 1.6.0_20, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Dataset consistency test:
[COMPLETE WITHOUT COORDINATES] {Node id=-15939 version=0 V } is not incomplete but has null coordinates
[COMPLETE WITHOUT COORDINATES] {Node id=-15938 version=0 V } is not incomplete but has null coordinates
[COMPLETE WITHOUT COORDINATES] {Node id=-15937 version=0 V } is not incomplete but has null coordinates
[COMPLETE WITHOUT COORDINATES] {Node id=-15936 version=0 V } is not incomplete but has null coordinates
Exception during dataset integrity test:
java.lang.NullPointerException

at org.openstreetmap.josm.data.osm.DatasetConsistencyTest.searchNodes(DatasetConsistencyTest.java:81)
at org.openstreetmap.josm.data.osm.DatasetConsistencyTest.runTest(DatasetConsistencyTest.java:139)
at org.openstreetmap.josm.data.osm.DatasetConsistencyTest.runTests(DatasetConsistencyTest.java:154)
at org.openstreetmap.josm.actions.ShowStatusReportAction.getReportHeader(ShowStatusReportAction.java:68)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:88)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.handle(BugReportExceptionHandler.java:41)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at java.awt.EventDispatchThread.handleException(Unknown Source)
at java.awt.EventDispatchThread.processException(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Plugins: PicLayer,livegps,measurement,surveyor,validator,wmsplugin
Plugin wmsplugin (Version: 21235)
Plugin PicLayer (Version: 20217)
Plugin validator (Version: 21177)
Plugin livegps (Version: 20431)
Plugin measurement (Version: 19681)
Plugin surveyor (Version: 19681)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Complete node with null coordinates: {Way id=-15934 version=7 VT nodes=[{Node id=-15936 version=0 V }, {Node id=-15937 version=0 V }, {Node id=-15938 version=0 V }]}Unexpected error. Please report it to http://josm.openstreetmap.de/ticket/3892
{Node id=-15936 version=0 V }
Coor is null

at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:379)
at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:386)
at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:63)
at org.openstreetmap.josm.data.osm.Way.load(Way.java:212)
at org.openstreetmap.josm.command.AddPrimitivesCommand.executeCommand(AddPrimitivesCommand.java:34)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:37)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:59)
at org.openstreetmap.josm.actions.PasteAction.pasteData(PasteAction.java:145)
at org.openstreetmap.josm.actions.PasteAction.actionPerformed(PasteAction.java:40)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by jttt

That's a new consistency test, probably just false positive. You can set debug.checkNullCoor to false in Einstein preferences to disable the test.

comment:2 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3257]) Fix #5032: Unexpected error during PASTE

comment:3 Changed 9 years ago by anonymous

Ticket #5036 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.