Modify

Opened 10 years ago

Closed 9 years ago

#4875 closed defect (fixed)

Display settings->Colors->Set all to default segfaults

Reported by: balrog-kun Owned by: balrog-kun
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Preferences->Display settings->Colors->Set all to default

Can anyone by the way tell me if there's a way to go back to the old wireframe mode? Recently all nodes with tags are white with no setting to change the colour and make them bigger than untagged nodes, nodes belonging to more than one way become bigger with no setting to change back.. as a result nodes belonging to more than one way and tagged now look identical with selected nodes.

On another note when trying to delete objects outside of the downloaded area, the clicks are ignored completely.

Please provide any additional information below. Attach a screenshot if
possible.

Build-Date: 2010-04-10 19:10:25
Revision: 3174
Is-Local-Build: true

Memory Usage: 109 MB / 433 MB (58 MB allocated, but free)
Java version: 1.6.0, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux


Plugins: PicLayer,multipoly,plastic_laf,terracer,wms-turbo-challenge2,wmsplugin
Plugin plastic_laf (Version: 19469)
Plugin wmsplugin (Version: 20566)
Plugin PicLayer (Version: 20217)
Plugin terracer (Version: 20084)
Plugin multipoly (Version: 19456)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.Preferences.getDefaultColor(Preferences.java:610)
	at org.openstreetmap.josm.gui.preferences.ColorPreference$3.actionPerformed(ColorPreference.java:184)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
	at java.awt.Dialog$1.run(Dialog.java:1039)
	at java.awt.Dialog$3.run(Dialog.java:1091)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1089)
	at java.awt.Component.show(Component.java:1419)
	at java.awt.Component.setVisible(Component.java:1372)
	at java.awt.Window.setVisible(Window.java:801)
	at java.awt.Dialog.setVisible(Dialog.java:979)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.setVisible(PreferenceDialog.java:85)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:38)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:34)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1170)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1211)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by stoecker

Owner: changed from team to balrog-kun
Status: newneedinfo

Could not reproduce here. Still an issue, if yes, add better description how to get the bug.

comment:2 Changed 9 years ago by jttt

Resolution: fixed
Status: needinfoclosed

(In [3194]) Fix #4875 Display settings->Colors->Set all to default segfaults

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain balrog-kun.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.