Modify

Opened 10 years ago

Closed 9 years ago

#4822 closed defect (fixed)

Loading WMS layer from file throws exception

Reported by: wittelw@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download a WMS layer and save it to disk.
  2. Restart JOSM and a gpx file and zoom to similar position
  3. Add a blank WMS layer and load the file.

Please let me know if you need more info. The file that was generated / loaded is 2.8 MB.

OS is Ubuntu Karmic (9.10) with kernel 2.6.31-20-generic on eeepc 901 with 1GB RAM

What is the expected result?
The WMS layer from disk would be displayed.

What happens instead?
Exception with option to send this bug. I was running josm-latest.jar when I saved the WMS layer but get same exception stack if I run josm-tested.jar.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-22 02:31:50
Last Changed Author: jttt
Revision: 3151
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-21 13:13:42 +0100 (Sun, 21 Mar 2010)
Last Changed Rev: 3151

Memory Usage: 34 MB / 63 MB (6 MB allocated, but free)
Java version: 1.6.0_15, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux


Plugin wmsplugin (Version: 20566)

java.lang.NullPointerException
	at wmsplugin.GeorefImage.paint(GeorefImage.java:63)
	at wmsplugin.WMSLayer.downloadAndPaintVisible(WMSLayer.java:246)
	at wmsplugin.WMSLayer.paint(WMSLayer.java:194)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:533)
	at javax.swing.JComponent.paintChildren(JComponent.java:864)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5124)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1475)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1406)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:294)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1220)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5072)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:803)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:714)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:694)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:128)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
	at java.awt.Dialog$1.run(Dialog.java:1045)
	at java.awt.Dialog$3.run(Dialog.java:1097)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1095)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:841)
	at java.awt.Dialog.setVisible(Dialog.java:985)
	at org.openstreetmap.josm.gui.HelpAwareOptionPane.showOptionDialog(HelpAwareOptionPane.java:241)
	at org.openstreetmap.josm.plugins.PluginHandler.confirmDeactivatingPluginAfterException(PluginHandler.java:830)
	at org.openstreetmap.josm.plugins.PluginHandler.disablePluginAfterException(PluginHandler.java:890)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:62)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handle(BugReportExceptionHandler.java:41)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at java.awt.EventDispatchThread.handleException(EventDispatchThread.java:388)
	at java.awt.EventDispatchThread.processException(EventDispatchThread.java:294)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:286)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by stoecker

Component: CoreCore imagery

comment:2 Changed 9 years ago by bastiK

Ticket #5187 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

This was probably fixed during wms plugin refactoring, the problematic line no longer exists.

comment:4 Changed 9 years ago by bastiK

Resolution: fixed
Status: closedreopened

True, but it broke elsewhere.

I'm at it...

comment:5 Changed 9 years ago by bastiK

fixed (In [o22854]).

comment:6 Changed 9 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.