Modify

Opened 10 years ago

Closed 10 years ago

#4821 closed defect (wontfix)

not only junctions marked with 5x5 node

Reported by: malenki Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: malenki

Description

After solving #2801 and #4820 the issue still remains that at a way which is splitted (due to a changing layer, bridge or anything you like) a 5x5 node shows up although the "junction" at this points exists only of the same way continuing itself.

Attachments (4)

Screenshot-Josm_style_filled.png (131.0 KB) - added by bastiK 10 years ago.
malenki style, filled nodes
Screenshot-style_frame.png (131.8 KB) - added by bastiK 10 years ago.
malenki style, normal frame
Screenshot-current.png (130.4 KB) - added by bastiK 10 years ago.
The current style
Screenshot-JOSM tagged-connected.png (23.2 KB) - added by bastiK 10 years ago.
normal node, tagged node, connected node and tagged&connected node

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by bastiK

I don't see a problem here. The fact, that the way is splitted is interesting information. Please suggest a better style.

comment:2 Changed 10 years ago by malenki

Cc: malenki added

Replying to bastiK:

I don't see a problem here. The fact, that the way is splitted is interesting information. Please suggest a better style.

In short my suggestion:
Keep the old "original look" (5x5) of tagged nodes for both wireframe and "normal" style and use the now new invented look "3x3 filled white" for the newly chosen informations to display (for both modes).
Users will appreciate the consistency in look and feel. They will surely be thankful (that is, if they knew) that they don't have to learn that 5x5 nodes now don't show tagged nodes anymore but junctions, and tagged nodes now changed from 5x5 to 3x3 filled white.

In long:
As I reported this bug yesterday there were made some fast changes in how nodes were displayed.
First nodes at splitted ways looked in mappaint "normal" style (has this one a name btw?) like tagged nodes in wireframe mode, the latter display mode remaining unchanged.
Then the look of nodes in wireframe mode was changed:
Nodes at splitted ways looked now like tagged nodes (5x5), the look of tagged nodes was changed from 5x5 to 3x3 filled which needed a sharp eye to distinguish them from normal empty nodes.
At the next step the look of tagged nodes was changed into "3x3 filled white color", the nodes of junctions and at splitted ways now look like tagged nodes looked before.
In normal mappaint style tagged nodes with unknown rendering are still displayed as "3x3 filled red colored" which makes them (as previously in wireframe mode) hard to distinguish from empty nodes.
This process looks like learning while doing, so please take a step back and overlook the changes made altogether. (see my concluded suggestion above).

Changed 10 years ago by bastiK

malenki style, filled nodes

Changed 10 years ago by bastiK

Attachment: Screenshot-style_frame.png added

malenki style, normal frame

Changed 10 years ago by bastiK

Attachment: Screenshot-current.png added

The current style

comment:3 Changed 10 years ago by bastiK

First of all I simply forgot about wireframe view, so this inconsistency was not my intention. But then I was reluctant to add the new color in default mappaint mode, because tagged nodes without icons can be quite scarce in some regions and the new color might then be confusing.

Your suggestion is not so bad, the disadvantage I see is that the "connection nodes" are harder to spot if they have the same size as normal nodes.

comment:4 Changed 10 years ago by malenki

Recently I looked a bit deeper in the enhanced setting and configured the the depiction of nods to my liking.
Imo the problem is that there is no way to display a tagged and connected node.

Either the connected node is not tagged and shows up as connected node
or it is tagged and shows up as tagged node but which doesn't tell the user if the node is tagged and connected or only tagged.

Regarding this its a mysterium for me that the look of tagged nodes in the new standard is now used for the newly invented displaying of connected nodes and the long-since existing tagged nodes got a new design.

I suggest to display the tagged nodes as they used to be (5x5 red empty) and create a new depiction for tagged&connected nodes which is a combination of tagged and connected node.

Maybe the connected nodes could be 3x3 filled white or 4x4 empty and the tagged&connected node would be the same surrounded by the red empty 5x5.

(Maybe the subject of this issue should be changed)

Changed 10 years ago by bastiK

normal node, tagged node, connected node and tagged&connected node

comment:5 Changed 10 years ago by bastiK

Let me summarize from my perspective: We had to choose a style for the newly introduced connection nodes. Since in normal mappaint mode the connection nodes are far more common than tagged nodes, they should get the most natural and best looking style modification. So I decided to "borrow" the enlarged-square-style from the tagged nodes, even if it alienates some users that are so much used to the old looking. (Considering wireframe view later, I got the idea to change the color of tagged nodes as well, so this might have looked a little like trial & error.)

Of course it would have been better if it had been configurable right from the beginning.

But I think it would be a little late to pick up your suggestions now. On top of that I still prefer the current style.

As you can see from the screenshot, in the default setting you can differentiate t&c-nodes, t-nodes and c-nodes. Doesn't this work with your customized settings? If one of the 2 styles is filled and the other is enlarged, it should work for you!

comment:6 Changed 10 years ago by malenki

But I think it would be a little late to pick up your suggestions now.

Maybe that is so since today r3201 == latest == tested.

On top of that I still prefer the current style.

So why don't close the issue.

Doesn't this work with your customized settings?
If one of the 2 styles is filled and the other is enlarged, it should work for you!


Missed that one since I prefer(red) empty nodes.

comment:7 in reply to:  6 Changed 10 years ago by bastiK

Resolution: wontfix
Status: newclosed

Replying to malenki:

But I think it would be a little late to pick up your suggestions now.

Maybe that is so since today r3201 == latest == tested.

No, r3196 from Monday was a tested version as well.

On top of that I still prefer the current style.

So why don't close the issue.

Since there was no comment from other users or developers (not even on the mailing lists unless I missed that), we can probably close it now.

Doesn't this work with your customized settings?
If one of the 2 styles is filled and the other is enlarged, it should work for you!


Missed that one since I prefer(red) empty nodes.

If the configuration options are not sufficient for your needs, please open another ticket and describe clearly what you like to achieve. This ticket is more about changing default behaviour.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.