Modify

Opened 12 years ago

Closed 6 years ago

Last modified 3 years ago

#4760 closed enhancement (wontfix)

Drag map using left button

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc: shirish

Description (last modified by akks)

Hi,

There is a discrepancy between JOSM's dragging action and *every other mapping application in the world*. In JOSM we must right-click and drag to move the map around. *Everyone else* uses the left button.

I find it very difficult to switch between the OSM Mapnik view on the OSM web pages and JOSM. It's utterly frustrating.

Please consider making the functions for selecting and dragging configurable. I wouldn't ask for these functions to be changed for everyone, but please make a configuration setting where I can select 'Left button drags map'. Please. I have been using JOSM for 6 months and it's fabulous *but* this L&R button swap is driving me crazy.

In my opinion the left button click should do the same as it currently does. A left button drag should move the map (it currently draws a rubberbanding selection box). A left button drag with the shift key should do the rubberbanding selection. A right click should bring up a context menu. Again, this should be configurable, especially not to annoy current users who are used to, or even like, the current operation.

Thank you,

An enthusiastic OSM contributor.

Attachments (0)

Change History (21)

comment:1 Changed 12 years ago by bastiK

I know what you mean, I don't like it either. However I wouldn't use shift+left-button-drag for box selection. To be consistent with the OSM website, this should zoom to the selected box!

I'm not sure what to do about box selection.

  • Extra tool for box selection on the left
  • ctrl-left-button-drag
  • right-button-drag

Btw., the context menu does work already (see slippy map plugin). But there is currently nothing to show in that menu...

comment:2 in reply to:  1 Changed 12 years ago by anonymous

Replying to bastiK:

I know what you mean, I don't like it either. However I wouldn't use shift+left-button-drag for box selection. To be consistent with the OSM website, this should zoom to the selected box!

Operation doesn't have to be entirely consistent with OSM. The only thing that really bothers me is left-click-and-drag to move the map. *Every* mapping website uses that operation, so it messes with my head when going from JOSM to another website (and vice versa).

It is true that shift-left-click-and-drag will zoom in OSM, but that's not the point. The point is that shift-left-click-and-drag will draw a rectangle. What happens next is application-specific (and even mode specific within an application).

As I said, changing the function to drag the map should be user configurable, so that users who are happy with it are not inconvenienced. If such a configuration were available I would use it immediately!! :)

Thank you.

comment:3 Changed 12 years ago by anonymous

Actually, Merkaartor does this. It has a 'single-button' mode which does, in my opinion, the Right Thing. Please incorporate a similar, switchable, mode in JOSM.

comment:4 Changed 12 years ago by Zverikk

This should be optional (and RMB by default). It will help tablet users (like me), but with mouse I think it's better to stick with the right button. Many people are already used to it.

comment:5 in reply to:  4 Changed 11 years ago by anonymous

Replying to Zverikk:

This should be optional (and RMB by default). It will help tablet users (like me), but with mouse I think it's better to stick with the right button. Many people are already used to it.

Many people are already used to it *in JOSM*, but the rest of the world uses left-click to drag, including Google, and OSM slippy map. I don't disagree that the default in JOSM should be right-click, but I desperately want the option to choose left-click!! Please!!

comment:6 Changed 9 years ago by tomashpilshchik@…

Here is another reason for making dragging with the left button an option: if there is an image background layer, clicking the right button brings up a popup menu. Or at least it does unless one presses the mouse button in some specific way which I cannto figure out. This is super frustrating.

comment:7 Changed 9 years ago by anonymous

Also - please, please: make it configurable. Even by obscure config file.

comment:8 Changed 9 years ago by akks

Description: modified (diff)

I tried to change dragging button in my code. Dragging works, but it seems to be real pain or unsolvable problem for programmers to implement it correctly: there are behavior conflicts with all left-dragging actions in different mapmodes (drag node, box-select, draw line, extrude, parallel, plugins, etc.)

Did you try TouchScreenHelper plugin, by the way? Maybe there is a way to improve it?

Last edited 9 years ago by akks (previous) (diff)

comment:9 Changed 9 years ago by Don-vip

Summary: Left button should drag map!! Please!!Drag map using left button

comment:10 Changed 6 years ago by openstreetmap.org-user-d1g

With iD as current editor in browser, JOSM should follow hot-keys most editors use. Left mouse drag should be used for map move.

Probably it make sense to refactor "activation system" in JOSM:

(chain of actions) -> button or plug-in action or menu selection

We should use common shortcuts between editors and not to relearn hotkeys each time (i.e. Ctrl+F is for search is a standard for every application).

PS. I don't get who downvoted this issue.

Last edited 6 years ago by openstreetmap.org-user-d1g (previous) (diff)

comment:11 in reply to:  10 Changed 6 years ago by stoecker

Replying to openstreetmap.org-user-d1g:

With iD as current editor in browser, JOSM should follow hot-keys most editors use. Left mouse drag should be used for map move.

Why should we? If you request that, ask iD to change their shortcuts. JOSM is on the world much longer.

Beside that, usually only newcomers ask for left-mouse moving. After some time most users prefer the JOSM way as it is much more intuitive and improves work flow a lot. You also see that e.g. on OpenLayers. Version 2 moves with left and middle mouse button. Version 3 also with right mouse button. Maybe JOSM had the right idea? :-)

We should use common shortcuts between editors and not to relearn hotkeys each time (i.e. Ctrl+F is for search is a standard for every application).

There is no chance to reach that goal in reality. The functions and requirements between applications differ to much. Regarding search: Also <F3> and <CTRL>+<H> and <CTRL>+<G> and </> and <CTRL>+<K>+<F> and ... There is no standard.

PS. I don't get who downvoted this issue.

I did now for example. :-)

comment:12 Changed 6 years ago by openstreetmap.org-user-d1g

Beside that, usually only newcomers ask for left-mouse moving.

Small things like this adds up and in the end, they won't use JOSM as "too complex compared (simple editor)". "It just works" decision making.

Why should we? If you request that, ask iD to change their shortcuts. JOSM is on the world much longer.

Assume, some person teaching newbies, He have to explain how editors are different in searching (or even map panning), so they could use this skill.

If all editors had same interface, then he wouldn't waste his time and time of the students explaining difference in the default settings.

It is okay to have 123456789 bazillions configurations in "real use", but not "by default" or when you tutor people.

Yes I know about "preconfigured", but it is not the case if editor simply presses "JOSM" in osm.org interface or download JOSM from his software packager or even JOSM main website.

If developers of editors tune some day-to-day tools so user don't have to readjust every time(having all tools with same shortcuts is indeed unrealistic) .

But when it comes to simple operations: multiple selection, move objects, move map - we could as for a standard way of doing this and optional ways (or legacy ways) for those who need it

You also see that e.g. on OpenLayers. Version 2 moves with left and middle mouse button. Version 3 also with right mouse button.

Version 3 uses both behaviours: http://openlayers.org/en/v3.14.2/examples/
http://leafletjs.com/ - uses only left mouse drag leaflet is more popular than openlayers at SA, not sure about deployment stats and users. Probably leaflet has bigger numbers.

Maybe JOSM had the right idea? :-)

Well, with better stats we could make a better decisions, but AFAIK there no good stats on this topic.

and ... There is no standard.

If you count all exotic software, yes. But if you open ubuntu, open notepad alternative they have, do search. It would be F3 or Ctrl+F. Do the same on RHEL, Cent OS. With gnome, they would have this boy by default: Finding text (Ctrl+F)

You should not only enumerate all possibilities, but also respect how often they are used (or will be used, if you plan for future).

There is no chance to reach that goal in reality.

If we count ALL editors ever existed in OSM, then yes. But if we count only top editors, then with heavy refactor it is possible to have iD, JOSM, P2 and Vespucci to have that common utility (simply use mouse drag to pan map)

Good thing we don't have to include emacs and vi/vim :-D

PS. I tried to reply without begin too verbose

Last edited 6 years ago by openstreetmap.org-user-d1g (previous) (diff)

comment:13 in reply to:  12 Changed 6 years ago by stoecker

Resolution: wontfix
Status: newclosed

Replying to openstreetmap.org-user-d1g:

Beside that, usually only newcomers ask for left-mouse moving.

Small things like this adds up and in the end, they won't use JOSM as "too complex compared (simple editor)". "It just works" decision making.

We often see that new mappers get introduced directly to JOSM nowadays in mapping parties, as JOSM is much better handling the complexity of the today map. I very seldom hear that user interface differences are a reason not to use JOSM. Usually from people who simply don't wont to learn anything but expect it to be like their mind says it should be.

Why should we? If you request that, ask iD to change their shortcuts. JOSM is on the world much longer.

[...]

If all editors had same interface, then he wouldn't waste his time and time of the students explaining difference in the default settings.

Again. Why should WE?. Over the year we hear again and again and that JOSM should follow whatever other editor (Potlatch in the past, now iD) for functions JOSM introduced. We put a lot of thinking also in such a minor task as assigning shortcuts and now each time somebody else decides to offer the same function JOSM should rework it's shortcuts. Sounds a bit strange to me.

and ... There is no standard.

If you count all exotic software, yes. But if you open ubuntu, open notepad alternative they have, do search. It would be F3 or Ctrl+F. Do the same on RHEL, Cent OS. With gnome, they would have this boy by default: Finding text (Ctrl+F)

This is no exotic software, but these were examples from the software I use every day which I could quote without thinking much in a few seconds.

Nevertheless this discussion is off-topic in this ticket.

Regarding the ticket itself: Left mouse movement is major work, has little benefits, will introduce a really large additional complexity to the already very complex code and has not been introduced in the last 6 years --> WONTFIX.

comment:14 Changed 6 years ago by simon04

Ticket #13751 has been marked as a duplicate of this ticket.

comment:15 Changed 6 years ago by simon04

Cc: shirish added

comment:16 Changed 4 years ago by jidanni

The problem isn't when using JOSM, the problem is when going back to the other 1000 programs.
That's when the confusion sets in. You don't know which hand to use anymore.
Therefore, just like

GNU Emacs can be programmed to emulate (more or less) most other editors...

JOSM should have a 'Google mode' etc. Thanks.

comment:17 Changed 4 years ago by anonymous

Request to change ticket status form "wontfix" to "open"

(Maybe there is somebody in the future who will do the implementation of this feature)
Or this isn't the right order, and only at that moment start-of-implementation the status will be changed?

By the way, I also what to have a function to drag the map by left mouse button :-)
I also think the map right-mouse-button-dragging situation is a huge barrier for user how don't often work with computers at all and also others.


comment:18 Changed 4 years ago by Don-vip

Request denied. JOSM developers are still the same and the complexity of switching button has not decreased, rather increased. If a brilliant and motivated developer wants to do this, nothing forbids to code it, THEN reopening the ticket with a patch attached. Leaving the ticket open will not make the feature appear magically.

comment:19 Changed 3 years ago by papab

I understand that it's probably too late to change, but this is unfortunate. I go back and forth to OSM iD, Qgis, and Qlandkarte (& google too). They all use left click to move the map.

Last edited 3 years ago by papab (previous) (diff)

comment:20 Changed 3 years ago by Don-vip

Ticket #18186 has been marked as a duplicate of this ticket.

comment:21 Changed 3 years ago by jidanni

Actually a slight enhancement #18300 to Plugin Touchscreenhelper will finally solve this issue for everybody.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.