Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#474 closed enhancement (duplicate)

Being unable to turn off node creation, without node-reuse being turned off.

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

If I have a way

---o---o---o---o

a

|

And I want to create a new t-junction at 'a', it instead snaps to the nearest node, if working at a reasonable zoom-out.

Rather than having to:
Select zoom, zoom in to area, create beginning of way, zoom out, pan to where you were before, selct creation tool, continue creating way.

Perhaps Alt-Gr would turn off node-reuse, but keep node creation?

Personally, I'd like a box which lets me select:

MetakeysDescriptionAutoConnectNew wayNode ReuseAutoinsert NodeKeep Node tags
NoneCreate/addyesnoyesyesno
ShiftCreate/add with no connectnonoyesyesno
NoneCreate/add nodeyesnoyesyesno
Shift-Alt-CtrlCreate new node/way copying tagsyesyesyesyesyes

A tooltip pops up if the user holds a metakey for a few seconds, listing the current settings.

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by Gabriel Ebner <ge@…>

Did you know you can zoom using the mouse wheel? I don't know if it's a good idea to add yet more modifiers...

comment:2 Changed 11 years ago by SpeedEvil

Doesn't work well - for example, If I'm tagging all features on a WMS image, I can't zoom and pan back to the original place, it's a seperate operation.
Neglecting the fact that zooming is slow.

comment:3 Changed 10 years ago by anonymous

Type: defectenhancement

comment:4 Changed 10 years ago by xeen

Resolution: duplicate
Status: newclosed

comment:5 Changed 10 years ago by xeen

Closed as duplicate of #383.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.