Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4727 closed defect (duplicate)

Error after load of osm file

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-12 02:31:30
Last Changed Author: jttt
Revision: 3118
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-11 21:20:58 +0100 (Thu, 11 Mar 2010)
Last Changed Rev: 3118

Memory Usage: 28 MB / 508 MB (6 MB allocated, but free)
Java version: 1.6.0_17, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Dataset consistency test:
No problems found

Plugins: wmsplugin
Plugin wmsplugin Version: 19992

java.lang.NullPointerException

at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawSegment(MapPainter.java:140)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawWay(MapPainter.java:91)
at org.openstreetmap.josm.gui.mappaint.LineElemStyle.paintPrimitive(LineElemStyle.java:198)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.drawWay(MapPaintVisitor.java:181)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.visitAll(MapPaintVisitor.java:698)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:268)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:496)
at javax.swing.JComponent.paintChildren(JComponent.java:866)
at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1042)
at javax.swing.JComponent.paint(JComponent.java:1038)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (1)

muggia.osm.zip (274.9 KB) - added by davalv@… 10 years ago.
Do not upload the file on OSM!

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by davalv@…

Attachment: muggia.osm.zip added

Do not upload the file on OSM!

comment:1 Changed 10 years ago by jttt

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by anonymous

Closed as duplicate of #4723.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.