Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4726 closed defect (duplicate)

crash when loading data from osm database

Reported by: trekki <bergenholtz@…> Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open josm
  2. load area (example: http://api.openstreetmap.org/api/0.6/map?bbox=7.1471428999999995,50.684033,7.150576099999999,50.6861538

What is the expected result?
the data of the loaded area should be shown

What happens instead?
crash

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-12 02:31:30
Last Changed Author: jttt
Revision: 3118
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-11 21:20:58 +0100 (Thu, 11 Mar 2010)
Last Changed Rev: 3118

Memory Usage: 69 MB / 2730 MB (31 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: wmsplugin,validator
Plugin wmsplugin Version: 19240
Plugin validator Version: 19229

java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawSegment(MapPainter.java:140)
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawWay(MapPainter.java:91)
	at org.openstreetmap.josm.gui.mappaint.LineElemStyle.paintPrimitive(LineElemStyle.java:198)
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.drawWay(MapPaintVisitor.java:192)
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.visitAll(MapPaintVisitor.java:698)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:268)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:496)
	at javax.swing.JComponent.paintChildren(JComponent.java:866)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1042)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:871)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:67)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler.handle(BugReportExceptionHandler.java:41)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at java.awt.EventDispatchThread.handleException(EventDispatchThread.java:395)
	at java.awt.EventDispatchThread.processException(EventDispatchThread.java:301)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:289)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by anonymous

Closed as duplicate of #4723.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.