Modify

Opened 11 years ago

Closed 11 years ago

#469 closed defect (wontfix)

enabling mappaint throws exception

Reported by: robert.merkel@… Owned by: framm
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

As soon as I enable mappaint, josm crashes with the exception below. I'm running the latest mappaint and josm off the website as of now.

I'm running Debian unstable with the Sun JRE. Java -version gives the following:

java version "1.6.0"
Java(TM) SE Runtime Environment (build 1.6.0-b105)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0-b105, mixed mode)

The exception follows. While josm is still functional without mappaint, it would be nice to have the fancy rendering...

org.openstreetmap.josm.plugins.PluginException: An error occoured in plugin mappaint

at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:119)
at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:56)
at org.openstreetmap.josm.plugins.PluginInformation.findPlugin(PluginInformation.java:202)
at org.openstreetmap.josm.gui.preferences.PluginPreference.ok(PluginPreference.java:279)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:77)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:50)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1170)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.menuDragMouseReleased(BasicMenuItemUI.java:1274)
at javax.swing.JMenuItem.fireMenuDragMouseReleased(JMenuItem.java:568)
at javax.swing.JMenuItem.processMenuDragMouseEvent(JMenuItem.java:465)
at javax.swing.JMenuItem.processMouseEvent(JMenuItem.java:411)
at javax.swing.MenuSelectionManager.processMouseEvent(MenuSelectionManager.java:304)
at javax.swing.plaf.basic.BasicPopupMenuUI$MouseGrabber.eventDispatched(BasicPopupMenuUI.java:802)
at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2360)
at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2252)
at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2210)
at java.awt.Component.dispatchEventImpl(Component.java:4308)
at java.awt.Container.dispatchEventImpl(Container.java:2116)
at java.awt.Component.dispatchEvent(Component.java:4240)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
at java.awt.Container.dispatchEventImpl(Container.java:2102)
at java.awt.Window.dispatchEventImpl(Window.java:2429)
at java.awt.Component.dispatchEvent(Component.java:4240)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Caused by: java.io.IOException: /home/rgmerk/.josm/plugins/mappaint.jar contains no manifest.

at org.openstreetmap.josm.plugins.PluginInformation.<init>(PluginInformation.java:69)
... 36 more

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by egroups_mip@…

I expected a similar error with mappaint on a Windows XP System running Sun Java 1.6.0_03.

JOSM (latest and previous versions) produces the following error when having loaded a GPX file, switched to the Draw Nodes tool, and clicking onto the map window:

An unexpected exception occured, that may come from in the 'mappaint plugin'.
According to the information within the plugin, the author is Nick Whitelegg / Ulf Lamping.
Should the plugin be disabled?
}}

Choosing 'No' shows the following message:
{{{
An unexpected exception occurred.

This is always a coding error. If you are runnning the latest JOSM version, please consider being kind and file a bug report.
}}}
Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 457
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 457
Last Changed Date: 2007-11-05 02:50:26 +0100 (Mon, 05 Nov 2007)


java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/osm/Segment
	at mappaint.MapPaintPlugin.layerAdded(MapPaintPlugin.java:92)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:121)
	at org.openstreetmap.josm.Main.addLayer(Main.java:272)
	at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:21)
	at org.openstreetmap.josm.Main.editLayer(Main.java:279)
	at org.openstreetmap.josm.command.AddCommand.<init>(AddCommand.java:44)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseClicked(DrawAction.java:124)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:2 Changed 11 years ago by anonymous

PS:
This is not limited to the "Draw nodes" tool. Exception occurs also when chosing "New" from the "File" menu (both with or without any data loaded previously).

comment:3 Changed 11 years ago by Gabriel Ebner <ge@…>

Resolution: wontfix
Status: newclosed

To egroups_mip@…: You're using an out-of-date mappaint plugin, please update it.

To the OP: It looks like you were using a broken mappaint jar. But that is now a thing of days long past now that mappaint is in JOSM proper.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.