Modify

Opened 12 years ago

Closed 10 months ago

#4504 closed enhancement (fixed)

Conditional warnings: display notification when an outlying operation is ignored due to saved preference

Reported by: Claudius Owned by: Don-vip
Priority: normal Milestone: 21.08
Component: Core Version:
Keywords: outside outlying Cc: skyper

Description (last modified by Don-vip)

How to reproduce:

  • Load any area that contains a way that reaches outside of the downloaded area.
  • Try deleting they way either by using DEL on the keyboard or the toolbar button

Result:
Nothing.

Expected result:
User should be able to delete a way even if it contains nodes outside the downloaded area. Warning dialog should be shown in this situation though.

Revision:
2959

Attachments (0)

Change History (10)

comment:1 Changed 12 years ago by mjulius

Could it be that you previously checked the "Do not ask again" checkbox and chose "No" in the warning that comes up normally?

If so, go to Advanced Preferences and look for "message.delete_outside_nodes" and set it to true.

comment:2 Changed 12 years ago by Gubaer

Keywords: r-2010-01-blocker removed
Priority: majorminor
Summary: Cannot delete a way that reaches outside loaded areaConditional warnings: Provide preference dialog for conditional warnings
Type: defectenhancement

If so, go to Advanced Preferences and look for "message.delete_outside_nodes" and set it to true.

This solved the issue for me.

I'm turning it into an enhancement and I'm trying to reformulate:

Implement a preference dialog for conditional messages. It should provide a checkbox for each conditional message dialog. If you check the checkbox the message dialog should be displayed, otherwise it shouldn't be displayed.

Rather a minor issue, though, and certainly not a blocker for the next release.

comment:3 Changed 12 years ago by skyper

Cc: skyper added
Type: enhancementdefect

I still think this is a defect, since you are not informed about why your edit is not accepted (delete outside nodes) which is only the side effect of deleting a way. I think JOSM should delete this ways with a warning and provide an option to keep or delete the outside nodes. If you choose delete, JOSM should still warn about not accepting the delete because "message.delete_outside_nodes" is TRUE.

comment:4 Changed 12 years ago by mjulius

Type: defectenhancement

I don't think it is a good idea to display a warning dialog about a suppressed warning dialog. The most I could imagine is a tooltip like non-modal info window that pops up somewhere and goes away again after a couple of seconds or when it is clicked on.

Regarding the warning in question here it might be a good idea if JOSM would distinguish between nodes that are to be deleted because they have been selected and nodes that are to be deleted because their parent way is deleted.

I am not sure it is a good idea to offer to just not delete these nodes because potentially this leaves a lot of orphaned nodes sitting around. A better option might be to offer to download the referrers for these nodes.

Anyway, the summary line clearly looks like an enhancement to me.

comment:5 Changed 12 years ago by anonymous

Keywords: r-2010-01-blocker added
Type: enhancementdefect

it is a defect, because the user don't know why it is not working. no message -> frustration

see also #817

comment:6 Changed 12 years ago by Gubaer

Keywords: r-2010-01-blocker removed
Type: defectenhancement

Removing blocker again and back to enhancement again. It isn't a defect.

Please log in if you flag a ticket as blocker or leave your email address.

comment:7 in reply to:  3 Changed 12 years ago by anonymous

Replying to skyper:

I think JOSM should delete this ways with a warning and provide an option to keep or delete the outside nodes. If you choose delete,should still warn about not accepting the delete because "message.delete_outside_nodes" is TRUE.

JOSM should temporally overwrite "message.delete_outside_nodes" and accept this change.

comment:8 Changed 10 months ago by Don-vip

Description: modified (diff)
Keywords: outside outlying added
Milestone: 21.08
Priority: minornormal
Summary: Conditional warnings: Provide preference dialog for conditional warningsConditional warnings: display notification when an outlying operation is ignored due to saved preference

comment:9 Changed 10 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:10 Changed 10 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 18181/josm:

fix #4504 - display notification when an outlying operation is ignored due to saved preference

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.