Modify

Opened 11 years ago

Closed 8 years ago

#4498 closed defect (fixed)

Can not upload GPS Track (OAuth)

Reported by: calibrator Owned by: team
Priority: normal Milestone:
Component: Plugin DirectUpload Version: latest
Keywords: Cc:

Description

LOSM 2959. Uploading GPS works OK with Normal_Authentication but impossible upload GPS track via plugin DirectUpload (v.19082) with OAuth (GPS Uploading granted in Oauth granted rights). See attache screens.

Attachments (3)

Settings_Oauth_Upload_GPS.PNG (23.2 KB) - added by calibrator 11 years ago.
No passw_GPS_UPL_Oauth.PNG (9.9 KB) - added by calibrator 11 years ago.
DirectUpload.patch (23.5 KB) - added by ax 11 years ago.

Download all attachments as: .zip

Change History (19)

Changed 11 years ago by calibrator

Changed 11 years ago by calibrator

Attachment: No passw_GPS_UPL_Oauth.PNG added

comment:1 Changed 11 years ago by stoecker

Component: PluginPlugin directupload

comment:2 Changed 11 years ago by stoecker

Ticket #4933 has been marked as a duplicate of this ticket.

comment:3 Changed 11 years ago by anonymous

Summary: Can not upload GPS Track (OAuth)[PATCH] Can not upload GPS Track (OAuth)

find attached a patch that

  • adds oauth support,
  • adds tag, description, and privacy history and autocomplete to the upload dialog,
  • changes the way the gpx layer to be uploaded is selected among all open layers. you don't have to activate the gpx layer anymore, but just select it (as in "zoom to layer"). this saves some mouse clicks and doesn't disrupt the editing process (the current active editing layer can stay active)
  • (hopefully) simplifies some of the code

developed against r3627, updated to the latest r3648 without problems. i did some testing and found no problems - no guarantees though.

note that i had to use some not so pretty workarounds around josm architectural shortcomings. i hope i find the time to address those by providing patches to josm core which define better interfaces. i wouldn't mind if someone beats me to it, though :)

comment:4 Changed 11 years ago by ax

this last comment by "anonymous" is mine. is there an issue with the trac login? as soon as i press "preview" or "submit", i am logged out ...

comment:5 Changed 11 years ago by stoecker

Hmm, you're sure? I heard some of such issues, but could never reproduce them.

comment:6 Changed 11 years ago by ax

yep, definitely. i log in and get a "logged in as ax" on the top right. clicking any link or submitting any form or just reloading the page gives me the "Login" link on the top right again, and forms being submitted as anonymous. i have to manually fill the "Your email or username" box. both firefox and google chrome. are there different user classes?

comment:7 Changed 11 years ago by stoecker

You turned off cookies?

comment:8 Changed 11 years ago by ax

no. i have both a trac_session and a trac_form_token cookie. doesn't help.

comment:9 Changed 11 years ago by stoecker

Can you try another browser or disable Firefox plugins? Trac needs both the cookies as well as the form tokens in the HTML code to properly recognice a session. Please open a new report for this issue. If you switch to http or would also be nice when you could record data transfer using wireshark or similar tools and send it to me. You should have my mail from josm-dev.

comment:10 Changed 11 years ago by ax

the reason for the trac auth issue seems to have been determined.

regarding the patch for the actual gps track upload issue: can i do anything to get someone to look at (and commit) it ?

Changed 11 years ago by ax

Attachment: DirectUpload.patch added

comment:11 Changed 11 years ago by ax

removed an unnecessary comment and an unnecessary super. from the patch.

comment:12 in reply to:  10 Changed 11 years ago by bastiK

Replying to ax:

the reason for the trac auth issue seems to have been determined.

regarding the patch for the actual gps track upload issue: can i do anything to get someone to look at (and commit) it ?

I'll care for the patches tomorrow.

comment:13 Changed 11 years ago by bastiK

applied the patch as a temporary solution. (In [o24239])

comment:14 Changed 11 years ago by bastiK

Summary: [PATCH] Can not upload GPS Track (OAuth)Can not upload GPS Track (OAuth)

comment:15 Changed 8 years ago by Don-vip

OAuth upload works now.

comment:16 Changed 8 years ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.