Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4379 closed defect (duplicate)

terracer fails (special condition only)

Reported by: dk1ri Owned by: team
Priority: normal Milestone:
Component: Plugin terracer Version:
Keywords: Cc:

Description

two ajacent buildings number 1 - 11 fails, number 2 - 22 ok
11 next to 12, no reverse order : direction of track opposite direction

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-02 02:32:19
Last Changed Author: jttt
Revision: 2561
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-01 21:37:23 +0100 (Tue, 01 Dec 2009)
Last Changed Rev: 2561

Memory Usage: 30 MB / 508 MB (6 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found

Plugins: AgPifoJ,buildings_tools,openstreetbugs,remotecontrol,terracer,utilsplugin,validator,wmsplugin
Plugin AgPifoJ Version: 18593
Plugin buildings_tools Version: 27
Plugin openstreetbugs Version: 18595
Plugin remotecontrol Version: 18678
Plugin terracer Version: 17874
Plugin utilsplugin Version: 18621
Plugin validator Version: 18848
Plugin wmsplugin Version: 19240

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Objekt {Node id=614820114 version=1 V lat=28.1577833,lon=-14.2292808} kann nicht zum Datensatz hinzugefügt werden, weil es bereits im Datensatz enthalten ist

at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:183)
at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:51)
at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:51)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:40)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:60)
at terracer.TerracerAction.terraceBuilding(TerracerAction.java:199)
at terracer.TerracerAction.actionPerformed(TerracerAction.java:111)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by bastiK

Component: CorePlugin terracer
Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by bastiK

Closed as duplicate of #4275.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.