Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4358 closed defect (duplicate)

josm-2818 freeze at startup: tageditor

Reported by: grossing Owned by: grossing
Priority: normal Milestone:
Component: Plugin Version: latest
Keywords: plugin tageditor Cc: florian@…

Description

When i start josm-latest, i get a window with status message

"Checking plugin preconditions... Loading plugin 'tageditor'...

and then happens nothing more. No CPU usage, only the window stays with these message until i kill JOSM.

Here is the log:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-01-12 02:32:13
Last Changed Author: mjulius
Revision: 2818
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-01-11 21:25:29 +0100 (Mon, 11 Jan 2010)
Last Changed Rev: 2818

Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
loading plugin 'openstreetbugs'
loading plugin 'PicLayer'
loading plugin 'tageditor'
org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin tageditor aufgetreten.
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:203)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:308)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:360)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:399)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:188)
Caused by: java.lang.InstantiationException: org.openstreetmap.josm.plugins.tageditor.TagEditorPlugin
	at java.lang.Class.newInstance0(Class.java:340)
	at java.lang.Class.newInstance(Class.java:308)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:199)
	... 4 more
2010-01-13 03:28:00
Full thread dump Java HotSpot(TM) 64-Bit Server VM (14.3-b01 mixed mode):

"TimerQueue" daemon prio=10 tid=0x0000000040887800 nid=0x425d in Object.wait() [0x00007f7d6716e000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7f28028588> (a javax.swing.TimerQueue)
	at javax.swing.TimerQueue.run(TimerQueue.java:232)
	- locked <0x00007f7f28028588> (a javax.swing.TimerQueue)
	at java.lang.Thread.run(Thread.java:619)

"AWT-EventQueue-0" prio=10 tid=0x00000000403e9000 nid=0x425a in Object.wait() [0x00007f7d7074e000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7ac4f848> (a java.awt.EventQueue)
	at java.lang.Object.wait(Object.java:485)
	at java.awt.EventQueue.getNextEvent(EventQueue.java:479)
	- locked <0x00007f7d7ac4f848> (a java.awt.EventQueue)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:236)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
	at java.awt.Dialog$1.run(Dialog.java:1045)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

"AWT-Shutdown" prio=10 tid=0x00000000403e8000 nid=0x4259 in Object.wait() [0x00007f7d7084f000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7ac77070> (a java.lang.Object)
	at java.lang.Object.wait(Object.java:485)
	at sun.awt.AWTAutoShutdown.run(AWTAutoShutdown.java:259)
	- locked <0x00007f7d7ac77070> (a java.lang.Object)
	at java.lang.Thread.run(Thread.java:619)

"AWT-XAWT" daemon prio=10 tid=0x00007f7d6c1a4000 nid=0x4258 runnable [0x00007f7d70950000]
   java.lang.Thread.State: RUNNABLE
	at sun.awt.X11.XToolkit.waitForEvents(Native Method)
	at sun.awt.X11.XToolkit.run(XToolkit.java:548)
	at sun.awt.X11.XToolkit.run(XToolkit.java:523)
	at java.lang.Thread.run(Thread.java:619)

"Java2D Disposer" daemon prio=10 tid=0x00007f7d6c24f000 nid=0x4257 in Object.wait() [0x00007f7d712ec000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7abc9a78> (a java.lang.ref.ReferenceQueue$Lock)
	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:118)
	- locked <0x00007f7d7abc9a78> (a java.lang.ref.ReferenceQueue$Lock)
	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:134)
	at sun.java2d.Disposer.run(Disposer.java:125)
	at java.lang.Thread.run(Thread.java:619)

"Low Memory Detector" daemon prio=10 tid=0x00007f7d6c001000 nid=0x4255 runnable [0x0000000000000000]
   java.lang.Thread.State: RUNNABLE

"CompilerThread1" daemon prio=10 tid=0x0000000040253800 nid=0x4254 waiting on condition [0x0000000000000000]
   java.lang.Thread.State: RUNNABLE

"CompilerThread0" daemon prio=10 tid=0x0000000040251000 nid=0x4253 waiting on condition [0x0000000000000000]
   java.lang.Thread.State: RUNNABLE

"Signal Dispatcher" daemon prio=10 tid=0x000000004024f000 nid=0x4252 waiting on condition [0x0000000000000000]
   java.lang.Thread.State: RUNNABLE

"Finalizer" daemon prio=10 tid=0x0000000040231000 nid=0x4251 in Object.wait() [0x00007f7d6acd3000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7b0a4f48> (a java.lang.ref.ReferenceQueue$Lock)
	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:118)
	- locked <0x00007f7d7b0a4f48> (a java.lang.ref.ReferenceQueue$Lock)
	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:134)
	at java.lang.ref.Finalizer$FinalizerThread.run(Finalizer.java:159)

"Reference Handler" daemon prio=10 tid=0x0000000040229800 nid=0x4250 in Object.wait() [0x00007f7d72dd4000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7aadc440> (a java.lang.ref.Reference$Lock)
	at java.lang.Object.wait(Object.java:485)
	at java.lang.ref.Reference$ReferenceHandler.run(Reference.java:116)
	- locked <0x00007f7d7aadc440> (a java.lang.ref.Reference$Lock)

"main" prio=10 tid=0x0000000040111000 nid=0x424c in Object.wait() [0x00007f7ffe231000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00007f7d7ac55430> (a java.awt.Component$AWTTreeLock)
	at java.lang.Object.wait(Object.java:485)
	at java.awt.Dialog.show(Dialog.java:1108)
	- locked <0x00007f7d7ac55430> (a java.awt.Component$AWTTreeLock)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:841)
	at java.awt.Dialog.setVisible(Dialog.java:985)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:347)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:179)
	at org.openstreetmap.josm.plugins.PluginHandler.confirmDisablePlugin(PluginHandler.java:582)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:313)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:360)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:399)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:188)

"VM Thread" prio=10 tid=0x0000000040223000 nid=0x424f runnable 

"GC task thread#0 (ParallelGC)" prio=10 tid=0x000000004011b000 nid=0x424d runnable 

"GC task thread#1 (ParallelGC)" prio=10 tid=0x000000004011d000 nid=0x424e runnable 

"VM Periodic Task Thread" prio=10 tid=0x00007f7d6c003800 nid=0x4256 waiting on condition 

JNI global references: 3200

Heap
 PSYoungGen      total 49152K, used 14819K [0x00007f7f252a0000, 0x00007f7f29ef0000, 0x00007f7ffa7f0000)
  eden space 33408K, 2% used [0x00007f7f252a0000,0x00007f7f2534edd0,0x00007f7f27340000)
  from space 15744K, 89% used [0x00007f7f27340000,0x00007f7f2810a0a8,0x00007f7f282a0000)
  to   space 17472K, 0% used [0x00007f7f28de0000,0x00007f7f28de0000,0x00007f7f29ef0000)
 PSOldGen        total 19840K, used 13396K [0x00007f7d7a7f0000, 0x00007f7d7bb50000, 0x00007f7f252a0000)
  object space 19840K, 67% used [0x00007f7d7a7f0000,0x00007f7d7b505298,0x00007f7d7bb50000)
 PSPermGen       total 22208K, used 22142K [0x00007f7d753f0000, 0x00007f7d769a0000, 0x00007f7d7a7f0000)
  object space 22208K, 99% used [0x00007f7d753f0000,0x00007f7d7698f988,0x00007f7d769a0000)

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by stoecker

Owner: changed from team to Gubaer

comment:2 Changed 10 years ago by Gubaer

(In [2837]) see #4358

comment:3 Changed 10 years ago by Gubaer

Owner: changed from Gubaer to grossing
Status: newneedinfo

Although I can't reproduce r2837 applies a slight change in the way the plugin main class is instantiated.

Still an issue in r2837?

comment:4 Changed 10 years ago by anonymous

Resolution: duplicate
Status: needinfoclosed

Most likely a duplicate of #4365.

Should be fixed in r2865

comment:5 Changed 10 years ago by anonymous

Closed as duplicate of #4365.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain grossing.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.