Modify

Opened 10 years ago

Closed 10 years ago

#4349 closed defect (fixed)

Upgrading to 2818 hangs on processing plugins

Reported by: anonymous Owned by: team
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc: delta_foxtrot2

Description

Waited 5+ minutes for something to happen, eventually killed the process, tried to restart same result.

End up deleting .josm directory, which causes a Null Pointer Exception:

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanSiteCacheFiles(ReadLocalPluginInformationTask.java:78)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanLocalPluginRepository(ReadLocalPluginInformationTask.java:130)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.realRun(ReadLocalPluginInformationTask.java:186)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:81)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:123)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanSiteCacheFiles(ReadLocalPluginInformationTask.java:78)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.scanLocalPluginRepository(ReadLocalPluginInformationTask.java:130)
	at org.openstreetmap.josm.plugins.ReadLocalPluginInformationTask.realRun(ReadLocalPluginInformationTask.java:186)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:81)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:123)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by anonymous

Even after removing the .josm directory, if you install new plugins JOSM hangs on start saying processing plugins...

comment:2 Changed 10 years ago by delta_foxtrot2

Cc: delta_foxtrot2 added

Thought I was logged in, and wasn't...

comment:3 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

Fixed in r2819. At least the NPE.

Couldn't reproduce JOSM hanging on startup, though.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.