Opened 8 years ago

Closed 8 years ago

#4319 closed defect (fixed)

ClassNotFoundException when uploading with 2773

Reported by: Claudius Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: template_report Cc:


What steps will reproduce the problem?

  1. Do some editing
  2. Try uploading

What is the expected result?
JOSM should start uploading.

What happens instead?
"An unexpected exception occured."

Please provide any additional information below. Attach a screenshot if

Repository Root:
Build-Date: 2010-01-08 09:50:27
Last Changed Author: Gubaer
Revision: 2773
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Date: 2010-01-08 10:29:53 +0100 (Fri, 08 Jan 2010)
Last Changed Rev: 2773

Memory Usage: 25 MB / 63 MB (2 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found

Plugins: remotecontrol,validator,wmsplugin
Plugin remotecontrol Version: 19298
Plugin validator Version: 19304
Plugin wmsplugin Version: 19306

java.lang.NoClassDefFoundError: org/apache/commons/codec/binary/Base64

at oauth.signpost.signature.OAuthMessageSigner.<init>(
at oauth.signpost.signature.HmacSha1MessageSigner.<init>(
at oauth.signpost.signature.OAuthMessageSigner.create(
at oauth.signpost.AbstractOAuthConsumer.<init>(
at oauth.signpost.basic.DefaultOAuthConsumer.<init>(
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)

Caused by: java.lang.ClassNotFoundException: org.apache.commons.codec.binary.Base64

at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
... 18 more

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by Gubaer

If you're familiar with SVN and ant, try to checkout the JOSM source and run ant dist. This creates a JOSM dist/josm-custom.jar build which includes the necessary Apache classes.

The "official" builds available from the JOSM wiki are still built by an undocumented, non-public script. Please wait for the next release, perhaps it will be updateded by then.

comment:2 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

Fixed with tomorrow morning build.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.