Modify

Opened 10 years ago

Closed 10 years ago

#4261 closed defect (fixed)

[PATCH] Selection information is not updated after undo/redo

Reported by: KalleLampila Owned by: jttt
Priority: normal Milestone:
Component: Core Version: latest
Keywords: undo, redo, selection, patch Cc:

Description

Example reproduce this issue. Select some way with tags. Delete tag in properties windows. Press undo button. tag that undo return is not show in properties windows even it should.

Currently code test is selection changed, but this in not work in cases when selection stay same but there is properties changed in selection. Following patch change that fireSelectionChanged is call after every undo and redo.

Attachments (1)

undo-selection-fix.diff (2.2 KB) - added by KalleLampila 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by KalleLampila

Attachment: undo-selection-fix.diff added

comment:1 Changed 10 years ago by stoecker

Owner: changed from team to jttt

Hmpf, I believe there was a reason for this and your fix is at wrong place. There should be a new signal for this.

@Jiri: I think this is an issue for you.

comment:2 Changed 10 years ago by stoecker

Ticket #4094 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2741]) Fixed #4261 Selection information is not updated after undo/redo, minor optimalizations

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.