Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4257 closed defect (duplicate)

Validator: False positives

Reported by: PHerison Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: validator false positive Cc:

Description

Today JOSM-Validator plugin showed me some strange warnings "Wegende nahe anderer Straße":
Case A:
http://www.openstreetmap.org/browse/way/6183385 (this is a bridge layer=1)
http://www.openstreetmap.org/browse/node/27240542 (member of ways underneath bridge)
Case B:
http://www.openstreetmap.org/browse/way/23599634 (motorway_link FROM motorway)
http://www.openstreetmap.org/browse/node/27240551 (memeber of motorway_link TO motorway)

Same category ("Wegende nahe anderem Weg"):
Case C:
http://www.openstreetmap.org/browse/way/5095282 (stream no layer)
http://www.openstreetmap.org/browse/node/261583131 (endnode of bridge over stream layer=1)
Case D:
http://www.openstreetmap.org/browse/way/5095283 (stream tunnel -1)
http://www.openstreetmap.org/browse/node/33578629 (end of nearby footway)

Current configuration:
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-02 02:32:19
Last Changed Author: jttt
Revision: 2561
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-01 21:37:23 +0100 (Tue, 01 Dec 2009)
Last Changed Rev: 2561

Ant-Version: Apache Ant 1.7.0
Author: Francisco R. Santos
Created-By: 14.3-b01 (Sun Microsystems Inc.)
Manifest-Version: 1.0
Plugin-Class: org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin
Plugin-Date: 2009-11-29T14:42:27.800882Z
Plugin-Description: An OSM data validator. It checks for problems in data, and provides fixes for the common ones. Spellcheck integrated for tag names.
Plugin-Link: http://wiki.openstreetmap.org/index.php/JOSM/Plugins/Validator
Plugin-Mainversion: 2452
Plugin-Version: 18848

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by e2jk

Summary: False poitivesFalse positives

comment:2 Changed 11 years ago by bastiK

Summary: False positivesValidator: False positives

comment:3 Changed 11 years ago by skyper

Keywords: false added; flase removed

comment:4 Changed 10 years ago by skyper

Resolution: duplicate
Status: newclosed

All your cases seem to be fixed, but there are some problems with this check.

comment:5 Changed 10 years ago by skyper

Closed as duplicate of #3531.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.