Modify

Opened 10 years ago

Closed 10 years ago

#4150 closed defect (worksforme)

java.lang.reflect.InvocationTargetException

Reported by: meppen7 Owned by: meppen7
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

  1. 'Download from OSM' an area. Download o. k.
  2. 'Download from OSM' a second area. The following error message is displayed.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-11 02:31:44
Last Changed Author: ce
Revision: 2608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-10 23:49:06 +0100 (Thu, 10 Dec 2009)
Last Changed Rev: 2608

Memory Usage: 51 MB / 1016 MB (9 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found

Plugins: AddrInterpolation,Create_grid_of_ways,DirectUpload,PicLayer,buildings_tools,colorscheme,dataimport,editgpx,graphview,lakewalker,livegps,measurement,michigan_left,multipoly,openstreetbugs,openvisible,osmarender,plastic_laf,remotecontrol,routing,slippymap,surveyor,tageditor,tagging-preset-tester,terracer,validator,walkingpapers,waydownloader,wayparts,wmsplugin
Plugin plastic_laf Version: 14016
Plugin AddrInterpolation Version: 18874
Plugin Create_grid_of_ways Version: 17367
Plugin DirectUpload Version: 17532
Plugin PicLayer Version: 18597
Plugin buildings_tools Version: 25
Plugin colorscheme Version: 18413
Plugin dataimport Version: 18071
Plugin editgpx Version: 18962
Plugin graphview Version: 18962
Plugin lakewalker Version: 18880
Plugin livegps Version: 18941
Plugin measurement Version: 18962
Plugin michigan_left Version: 18084
Plugin multipoly Version: 18962
Plugin openstreetbugs Version: 18962
Plugin openvisible Version: 17536
Plugin osmarender Version: 18971
Plugin remotecontrol Version: 18678
Plugin routing Version: 18962
Plugin slippymap Version: 18805
Plugin tageditor Version: 18955
Plugin tagging-preset-tester Version: 14015
Plugin terracer Version: 18924
Plugin validator Version: 18962
Plugin walkingpapers Version: 18597
Plugin waydownloader Version: 18962
Plugin wayparts Version: ${version.entry.commit.revision}
Plugin wmsplugin Version: 18953
Plugin surveyor Version: 18503

java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:68)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:105)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.AbstractMethodError: org.openstreetmap.josm.plugins.wayparts.data.WaypartData.dataChanged()V

at org.openstreetmap.josm.data.osm.DataSet.fireDataChanged(DataSet.java:820)
at org.openstreetmap.josm.data.osm.DataSet.endUpdate(DataSet.java:811)
at org.openstreetmap.josm.data.osm.DataSetMerger.merge(DataSetMerger.java:377)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:282)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:159)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:70)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:78)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by jttt

Owner: changed from team to meppen7
Status: newneedinfo

wayparts plugin needs to be updated. Please contact author of the plugin and let him know about the problem.

comment:2 Changed 10 years ago by stoecker

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain meppen7.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.