Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4103 closed defect (fixed)

Exception on undo

Reported by: Daeron Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

While undoing a node deletion (the was a first node of a way) the following exception occurred:

Build-Date: 2009-12-06 00:34:20		
Revision: 2578
Is-Local-Build: true

Memory Usage: 231 MB / 910 MB (119 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found


Plugins: PicLayer,lakewalker,measurement,validator,wmsplugin
Plugin PicLayer Version: 18597
Plugin lakewalker Version: 18962
Plugin measurement Version: 18962
Plugin validator Version: 18962
Plugin wmsplugin Version: 18953

java.lang.ClassCastException: org.openstreetmap.josm.data.osm.Way cannot be cast to [Lorg.openstreetmap.josm.data.osm.OsmPrimitive;
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:895)
	at org.openstreetmap.josm.data.osm.DataSet.reindexNode(DataSet.java:765)
	at org.openstreetmap.josm.data.osm.DataSet.fireNodeMoved(DataSet.java:858)
	at org.openstreetmap.josm.data.osm.Node.setCoor(Node.java:26)
	at org.openstreetmap.josm.data.osm.Node.load(Node.java:132)
	at org.openstreetmap.josm.command.Command.undoCommand(Command.java:94)
	at org.openstreetmap.josm.command.SequenceCommand.undoCommands(SequenceCommand.java:76)
	at org.openstreetmap.josm.command.SequenceCommand.undoCommand(SequenceCommand.java:81)
	at org.openstreetmap.josm.data.UndoRedoHandler.undo(UndoRedoHandler.java:72)
	at org.openstreetmap.josm.actions.UndoAction.actionPerformed(UndoAction.java:34)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1633)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2839)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:267)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:216)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2916)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2908)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2802)
	at java.awt.Component.processEvent(Component.java:6040)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1850)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:712)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:990)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:855)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:676)
	at java.awt.Component.dispatchEventImpl(Component.java:4502)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2583]) Fix #4103 Exception on undo

comment:2 Changed 12 years ago by stoecker

Ticket #4095 has been marked as a duplicate of this ticket.

comment:3 Changed 12 years ago by stoecker

Ticket #4091 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.