Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4059 closed defect (fixed)

Relation history window does not show up

Reported by: Nakor Owned by: Nakor
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Gubaer)

If I select a relation and ask for its history, the history is downloaded from OSM but the history window never shows up afterwards.

Closing as worksforme.

Attachments (1)

HistoryRelationMemberException.patch (1.2 KB) - added by mjulius 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Nakor

Ticket #4058 has been marked as a duplicate of this ticket.

comment:2 Changed 12 years ago by mjulius

Owner: changed from team to Nakor
Status: newneedinfo

I can not reproduce that in r2554. What exactly are you doing (step-by-step)?

comment:3 Changed 12 years ago by Nakor

I cannot reproduce it any more. I do not know if this can be on any help, but this was on an out-dated relation (i.e. a modification that has been modified on OSM in the meantime).

comment:4 in reply to:  3 Changed 12 years ago by Gubaer

Description: modified (diff)
Resolution: worksforme
Status: needinfoclosed

Replying to Nakor:

I cannot reproduce it any more. I do not know if this can be on any help, but this was on an out-dated relation (i.e. a modification that has been modified on OSM in the meantime).

comment:5 Changed 12 years ago by mjulius

Resolution: worksforme
Status: closedreopened

I was able to narrow down the issue using the data attached to #4060.

The issue comes up when one tries to show the history of a modified relation that has a new way added. In this case JOSM wants to add the current data to the history as "latest" and RelationMember throws an IllegalArgumentException when the new way (with negative ID) is to be added. And because this is happening in a sub-thread this exception is ignored. (This is probably a bug on its own.)

The attached patch simply gets rid of the exception.

Changed 12 years ago by mjulius

comment:6 Changed 12 years ago by jttt

Resolution: fixed
Status: reopenedclosed

(In [2561]) Applied #4059 by mjulius - Relation history window does not show up

comment:7 Changed 12 years ago by anonymous

Ticket #4072 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Nakor.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.