Modify

Opened 13 years ago

Closed 13 years ago

#3972 closed defect (fixed)

null pointer exception validator

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Gubaer)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-11-17 02:31:54
Last Changed Author: jttt
Revision: 2466
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-11-16 20:49:05 +0100 (Mon, 16 Nov 2009)
Last Changed Rev: 2466

Memory Usage: 155 MB / 1016 MB (64 MB allocated, but free)
Java version: 1.6.0_0

Plugins: AddrInterpolationAgPifoJCreate_grid_of_waysDirectUploadbuildings_toolscolorschemedataimporteditgpxgraphviewmeasurementmultipolyopenvisibleosmarenderremotecontrolroutingterracerutilspluginwalkingpaperswaydownloaderwmsplugin
Plugin AddrInterpolation Version: 18503
Plugin AgPifoJ Version: 18593
Plugin Create_grid_of_ways Version: 17367
Plugin DirectUpload Version: 17532
Plugin buildings_tools Version: 24
Plugin colorscheme Version: 18413
Plugin dataimport Version: 18071
Plugin editgpx Version: 18595
Plugin graphview Version: 18593
Plugin measurement Version: 18595
Plugin multipoly Version: 18415
Plugin openvisible Version: 17536
Plugin osmarender Version: 18480
Plugin remotecontrol Version: 18503
Plugin routing Version: 18597
Plugin terracer Version: 17874
Plugin utilsplugin Version: 18621
Plugin validator Version: 18623
Plugin walkingpapers Version: 18597
Plugin waydownloader Version: 18617
Plugin wmsplugin Version: 18625

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.validator.tests.TagChecker.checkPrimitive(TagChecker.java:444)
at org.openstreetmap.josm.plugins.validator.tests.TagChecker.visit(TagChecker.java:378)
at org.openstreetmap.josm.data.osm.Way.visit(Way.java:137)
at org.openstreetmap.josm.plugins.validator.Test.visit(Test.java:151)
at org.openstreetmap.josm.plugins.validator.tests.TagChecker.visit(TagChecker.java:588)
at org.openstreetmap.josm.plugins.validator.ValidateUploadHook.checkUpload(ValidateUploadHook.java:61)
at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:152)
at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:168)
at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:193)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
at java.awt.Component.processMouseEvent(Component.java:6108)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:5873)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (3)

error.osm (65.4 KB) - added by dieterdreist 13 years ago.
error2.osm (69.9 KB) - added by dieterdreist 13 years ago.
the file after text modification (deleted object with ID -10 from relation) and editing afterwards in JOSM
error2.png (55.6 KB) - added by dieterdreist 13 years ago.
screeenshot of conflicts

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by dieterdreist

Attachment: error.osm added

Changed 13 years ago by dieterdreist

Attachment: error2.osm added

the file after text modification (deleted object with ID -10 from relation) and editing afterwards in JOSM

Changed 13 years ago by dieterdreist

Attachment: error2.png added

screeenshot of conflicts

comment:1 Changed 13 years ago by dieterdreist

I then tried to solve the problem by deleting the object with ID -10 from the relation. The file (error.osm) opened in JOSM without errors. I edited it then but on upload-trial there was another problem (node changed on server or something like this -> synchronize everything -> lots of conflicts). The file error2.osm and Screenshot was saved after synchronizing (should contain the new conflicts, I never touched most of the items with the conflicts).
I guess the problem is arising from deleting elements from relations outside the relation editor (in the properties-window).

comment:2 Changed 13 years ago by Gubaer

(In [2472]) Make sure getErrors() never returns null, see #3972

comment:3 Changed 13 years ago by Gubaer

Description: modified (diff)
Resolution: fixed
Status: newclosed

should be fixed in r2472. Please upgrade.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.