Modify

Opened 10 years ago

Closed 6 years ago

#3971 closed enhancement (wontfix)

Add class to handle NearMap's maximum zoom level, based on JMapViewer's AbstractOsmTileSource class for NearMap in JOSM

Reported by: morb_au Owned by: framm
Priority: normal Milestone:
Component: Core imagery Version: latest
Keywords: slippymap nearmap zoom mapviewer abstractosmtilesource Cc:

Description (last modified by Don-vip)

This relates to http://trac.openstreetmap.org/ticket/2429 and the files in http://svn.openstreetmap.org/applications/viewer/jmapviewer/src/org/openstreetmap/gui/jmapviewer ...

The NearMap imagery can go to zoom level 24, but the JMapViewer in JOSM only goes to layer 18 by default.

There are 2 solutions known - one (by me, morb_au) changes the default abstractosmtilesource to maximum zoom level 24, but this seems to break non-nearmap sources if they aren't explicitly set to maximum zoom 18 (my attached file does this for mapnik but I don't know if there are other layer types that need the fix).

The other (by Michael, http://lists.openstreetmap.org/pipermail/talk-au/2009-November/003990.html) sets up a new class based on abstractosmtilesource but this has the disadvantage of needing to be further patched if you want to choose a particular nearmap imagery date.

So my long term preference is to change the default maxzoom to 24, and allow users to choose the imagery date through JOSM preferences (e.g. through the slippymap.custom_tile_source_1 settings)

Attachments (1)

OsmTileSource.java (3.4 KB) - added by morb_au 10 years ago.
Example source code that makes Nearmap work to zoom 24 and Mapnik remaining to zoom 18, based on the version in http://svn.openstreetmap.org/applications/viewer/jmapviewer/src/org/openstreetmap/gui/jmapviewer

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by morb_au

Attachment: OsmTileSource.java added

Example source code that makes Nearmap work to zoom 24 and Mapnik remaining to zoom 18, based on the version in http://svn.openstreetmap.org/applications/viewer/jmapviewer/src/org/openstreetmap/gui/jmapviewer

comment:1 Changed 8 years ago by stoecker

Ticket #3985 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by Don-vip

Description: modified (diff)
Resolution: wontfix
Status: newclosed

Wontfix: We are no longer allowed to use Nearmap for OSM mapping since we have changed the license. See http://wiki.openstreetmap.org/wiki/NearMap_PhotoMaps.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.